Minimum Spanning Tree

滴答滴答---题目链接 

For a given weighted graph G=(V,E)G=(V,E), find the minimum spanning tree (MST) of GGand print total weight of edges belong to the MST.

Input

In the first line, an integer nn denoting the number of vertices in GG is given. In the following nn lines, a n×nn×n adjacency matrix AA which represents GG is given. aijaijdenotes the weight of edge connecting vertex ii and vertex jj. If there is no edge between ii and jj, aijaij is given by -1.

Output

Print the total weight of the minimum spanning tree of GG.

Constraints

  • 1≤n≤1001≤n≤100
  • 0≤aij≤2,0000≤aij≤2,000 (if aij≠−1aij≠−1)
  • aij=ajiaij=aji
  • GG is a connected graph

Sample Input 1

5
 -1 2 3 1 -1
 2 -1 -1 4 -1
 3 -1 -1 1 1
 1 4 1 -1 3
 -1 -1 1 3 -1

Sample Output 1

5

Reference

Introduction to Algorithms, Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. The MIT Press.

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=101;
const int inf=0x3f3f3f;
int n,e[maxn][maxn];
int prim()
{
    int u,ans;
    int d[maxn];//权值最小的边权
    int p[maxn];//标记v父亲结点
    int color[maxn];//访问状态
    for(int i=0; i<n; i++)
    {
        d[i]=inf;
        p[i]=-1;
        color[i]=0;
    }
    d[0]=0;
    while(1)
    {
        ans=inf;
        u=-1;
        for(int i=0; i<n; i++)
        {
            if(ans>d[i]&&color[i]!=2)
            {
                u=i;
                ans=d[i];
            }
        }
        if(u==-1)break;
        color[u]=2;
        for(int v=0; v<n; v++)
        {
            if(color[v]!=2&&e[u][v]!=inf)
            {
                if(d[v]>e[u][v])
                {
                    d[v]=e[u][v];
                    p[v]=u;
                   // color[v]=1;
                }
            }
        }


    }
    int sum=0;
    for(int i=0; i<n; i++)
    {
        if(p[i]!=-1)
            sum+=e[i][p[i]];
    }
    return sum;

}
int main()
{
    cin>>n;
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
        {
            int x;
            cin>>x;
            if(x==-1)
                e[i][j]=inf;
            else e[i][j]=x;
        }
    printf("%d\n",prim());
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值