hdu2955--Robberies(0/1背包)

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
/找准谁是背包的容量,刚开始理解错题的意思了,一直没对,后来看了别人的说吧抢的钱看成背包的容量,对应数组的值就是抢对应的钱逃跑的概率/

在这里插入代码片
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

double dp[100000];  //dp[i]表示偷i百万,逃跑的概率,越大越好 
int w[105];  //价值
double pi[105];  //被抢劫的概率 
int main()
{
	int t;
	cin>>t;
	while(t--){
		memset(dp,0,sizeof(dp));
		memset(w,0,sizeof(w));
		memset(pi,0,sizeof(pi));
		dp[0] = 1;  //表示不抢的话,就不会被抓,逃跑概率为1 
		double p;int n;int sum=0;
		cin>>p>>n;
		for(int i=1;i<=n;i++){
			cin>>w[i]>>pi[i];
			sum+=w[i];
		}
		for(int i=1;i<=n;i++){
			for(int j=sum;j>=w[i];j--)
			dp[j] = max(dp[j],dp[j-w[i]]*(1-pi[i]));//乘上的是对应该银行逃跑的概率
		}
		for(int i=sum;i>=0;i--){
			if(dp[i] >= 1-p){  //如果大于给定逃跑的概率就输出
				cout<<i<<endl;
				break;
			}
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

译制片~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值