*寒假水23——MAX NUM

 

There are some students in a class, Can you help teacher find the highest student .

InputThere are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.OutputFor each case output the highest height, the height to two decimal plases;Sample Input

2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00

Sample Output

180.00
182.00

 

#include<stdio.h>

int main()
{
	int n,m,i,j;
	double a,b,t;
	
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d%lf",&m,&a);
		for(j=0;j<m-1;j++)
		{
			scanf("%lf",&b);
			if(b>a) a=b;
		}
		printf("%.2lf\n",a);
	}
	
	return 0;
} 

题解:又是找最大数。。。。。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值