[数学][第二阶段-简单数学题][HDOJ-2071]Max Num

81 篇文章 0 订阅
38 篇文章 0 订阅
Problem Description
There are some students in a class, Can you help teacher find the highest student .
 


Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 


Output
For each case output the highest height, the height to two decimal plases;
 


Sample Input
  
  
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
 


Sample Output
  
  
180.00 182.00
 


import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		
		int n = in.nextInt();
		while(n>0){
			int m = in.nextInt();
			double[] highest = new double[m];
			int i,j;
			for(i=0;i<m;i++)
				highest[i]=in.nextDouble();
			
			double max=highest[0];
			for(i=0;i<m;i++)
				if(highest[i]>max)
					max=highest[i];
			System.out.println(String.format("%.2f", max));
			n--;
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值