思科交换机配置维护手册

一、端口配置

1.1 配置一组端口

configure terminal 进入配置状态

interface range { port-range } 进入组配置状态

可以使用平时的端口配置命令进行配置

end 退回

show interfaces [ interface-id ] 验证配置

copy running-config startup-config 保存

当使用 interface range 命令时有如下的规则 :

有效的组范围 :

vlan 从 1 到 4094

fastethernet 槽位 /{ first port } - { last port }, 槽位为 0

gigabitethernet 槽位 /{ first port } - { last port }, 槽位为 0

port-channel port-channel-number - port-channel-number , port-channel 号从 1到 64端口号之间需要加入空格,如: interface range fastethernet 0/1 – 5 是有效的,而interface range fastethernet 0/1-5 是无效的 .

interface range 命令只能配置已经存在的 interface vlan 所有在同一组的端口必须是相同类别的。

见以下例子 :

Switch# configure terminal

Switch(config)# interface range fastethernet0/1 - 5

Switch(config-if-range)# no shutdown

以下的例子显示使用句号来配置不同类型端口的组 :

Switch# configure terminal

Switch(config)# interface range fastethernet0/1-3, gigabitethernet0/1- 2 

Switch(config-if-range)# no shutdown

1.2 配置二层端口

1.2.1 配置端口速率及双工模式

1 configure terminal 进入配置状态 .

2 interface interface-id

进入端口配置状态 .

3 speed { 10 | 100 | 1000 | auto | nonegotiate } 设置端口速率

注:1000 只工作在千兆口 . GBIC 模块只工作在 1000 Mbps下. nonegotiate 只能在这些 GBIC上用 1000BASE-SX, -LX, and -ZX GBIC.

4 duplex { auto | full | half } 设置全双工或半双工 .

5 end 退出

6 show interfaces interface-id

显示有关配置情况

7 copy running-config startup-config 保存

Switch# configure terminal

Switch(config)# interface fastethernet0/3

Switch(config-if)# speed 10

Switch(config-if)# duplex half

1.2.2 端口描述

1 configure terminal 进入配置模式

2 interface interface-id 进入要加入描述的端口

3 description string 加入描述 ( 最多 240个字符).

4 end 退回.

5 show interfaces interface-id description  or

show running-config验证.

6 copy running-config startup-config 保存

1.2.3 配置三层口

Catalyst 3750 支持三种类型的三层端口 :

SVIs: 即 interface vlan三层以太网通道口( EtherChannel)

.路由口:路由口是指某一物理端口在端口配置状态下用 no switchport 命令生成的端口

所有的三层都需要 IP 地址以实现路由交换

配置步骤如下:

1 configure terminal 进入配置状态

2 interface {{ fastethernet | gigabitethernet } interface-id } | { vlan vlan-id } | { port-channelport-channel-number } 进入端口配置状态

3 no switchport 把物理端口变成三层口

4 ip address ip_address subnet_mask 配置 IP 地址和掩码

5 no shutdown 激活端口

6 end 退出

7 show interfaces [ interface-id ]

show ip interface [ interface-id ]

show running-config interface [ interface-id ] 验证配置

8 copy running-config startup-config 保存配置

配置举例如下:

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z. Switch(config)# interface gigabitethernet0/2

Switch(config-if)# no switchport

Switch(config-if)# ip address 192.20.135.21 255.255.255.0

Switch(config-if)# no shutdown

Switch(config-if)# end

show ip interface 命令 :

Switch# show ip interface gigabitethernet0/2

GigabitEthernet0/2 is up, line protocol is up

 Internet address is 192.20.135.21/24

 Broadcast address is 255.255.255.255

 Address determined by setup command

 MTU is 1500 bytes

 Helper address is not set

 Directed broadcast forwarding is disabled

<output truncated>

1.3 监控及维护端口

1.3.1 监控端口和控制器的状态

主要命令见下表:

show interfaces [ interface-id ] 显示所有端口或某一端口的状态和配置.

show interfaces interface-id status[ err-disabled ] 显示一系列端口的状态或错误-关闭的状态

show interfaces [ interface-id ] switchport 显示二层端口的状态,可以用来决定此口是否为二层或三层口。

show interfaces [ interface-id ]   description  显示端口描述

show ip interface [ interface-id ] 显示所有或某一端口的 IP 可用性状态

show running-config interface [ interface-id ] 显示当前配置中的端口配置情况

show version 显示软硬件等情况

举例如下 :

Switch# show interfaces status

Port Name Status Vlan Duplex Speed Type

Gi0/1 connected routed a-full a-100 10/100/1000Base TX

Gi0/2 wce server 20.20.2 disabled routed auto auto 10/100/1000Base TX

Gi0/3 ip wccp web-cache notconnect routed auto auto 10/100/1000Base TX

Gi0/4 notconnect routed auto auto 10/100/1000Base TX

Gi0/5 notconnect routed auto auto 10/100/1000Base TX

Gi0/6 disabled routed auto auto 10/100/1000Base TX

Gi0/7 disabled routed auto auto 10/100/1000Base TX

Gi0/8 disabled routed auto 100 10/100/1000Base TX

Gi0/9 notconnect routed auto auto 10/100/1000Base TX

Gi0/10 notconnect routed auto auto 10/100/1000Base TX

Gi0/11 disabled routed auto auto unknown

Gi0/12 notconnect routed auto auto unknown

Switch# show interfaces fastethernet 0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: static access

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Unknown unicast blocked: disabled Unknown multicast blocked: disabled

Voice VLAN: dot1p (Inactive)

Appliance trust: 5

Switch# show running-config interface fastethernet0/2

Building configuration...

Current configuration : 131 bytes

!

interface FastEthernet0/2

 switchport mode access

 switchport protected

 no ip address

 mls qos cos 7

 mls qos cos override

end

1.3.2 刷新、重置端口及计数器

clear counters [ interface-id ] 清除端口计数器 .

clear interface interface-id 重置某一端口的硬件逻辑

clear line [ number | console 0 | vty number] 重置异步串口的硬件逻辑

Note clear counters 命令只清除用 show interface 所显示的计数,不影响用 snmp 得到的计数

举例如下:

Switch# clear counters fastethernet0/5

Clear "show interface" counters on this interface [confirm] y

Switch#

*Sep 30 08:42:55: %CLEAR-5-COUNTERS: Clear counter on interface FastEthernet0/5 by vty1 (171.69.115.10)

可使用 clear interface 或 clear line 命令来清除或重置某一端口或串口,

在大部分情况下并不需要这样做 :

Switch# clear interface fastethernet0/5

1.3.3 关闭和打开端口

1 configure terminal 进入配置状态

2 interface {vlan vlan-id } | {{ fastethernet | gigabitethernet } interface-id } | { port-channel  port-channel-number } 选择要关闭的端口

3 shutdown 关闭

4 end 退出

5 show running-config 验证

使用 no shutdown 命令重新打开端口 .

举例如下 :

Switch# configure terminal

Switch(config)# interface fastethernet0/5

Switch(config-if)# shutdown

Switch(config-if)#

*Sep 30 08:33:47: %LINK-5-CHANGED: Interface FastEthernet0/5, changed state to a

administratively down

Switch# configure terminal

Switch(config)# interface fastethernet0/5Switch(config-if)# no shutdown

Switch(config-if)#

*Sep 30 08:36:00: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up

二、配置 VLAN

2.1 VLAN 论述

一个 VLAN 就是一个交换网,其逻辑上按功能、项目、应用来分而不必考虑用户的物理位置。任何交换口都可以属于某一 VLAN, IP 包、广播包及组播包均可以发送或广播给在此VLAN 内的最终用户。每一个 VLAN 均可看成是一个逻辑网络,发往另一 VLAN 的数据包必须由路由器或网桥转发(如下图) 。由于 VLAN 被看成是一个逻辑网络,其具有自己的网桥管理信息庫 (MIB) 并可支持自己的生成树

VLAN 作为逻辑定义的网络示意图

VLAN常常与 IP 子网相联系,同一 IP 子网属于同一 VLAN。在 3550 上 VLAN之间的数据包可以由 VLAN端口进行转发。

可支持的 VLAN

Catalyst 3750 交换机支持 1005 个 VLAN,可以分别是 VTP client, server, 及transparent modes. VLAN 号可以从 1 到 4094. VLAN 号 1002到 1005保留给令牌环及 FDDI VLAN.

VTP只能学习到普通范围的 VLAN, 即从 VLAN到 1 到 1005; VLAN号大于 1005属于扩展 VLAN,不存在 VLAN数据庫中。 交换机必须配置成VTP透明模式当需要生成 VLAN 号从 1006 到 4094.

本交换机支持基于每一 VLAN的生成树 (PVST),最多支持 128 个生成树。本交换机支持 ISL 及 IEEE 802.1Q trunk 二种封装。

2.2 配置正常范围的 VLAN

VLAN 号 1, 1002 到 1005 是自动生成的不能被去掉。

VLAN号 1 到 1005的配置被写到文件 vlan.dat 中, 可以用 show vlan 命令查看,vlan.dat 文件存放在 NVRAM中.

注意 不要手工删除 vlan.dat 文件,可能造成 VLAN 的不完整。 如要删除 vlan 需要用有关的命令来进行

2.2.1 生成、修改以太网 VLAN

1 configure terminal 进入配置状态

2 vlan vlan-id 输入一个 VLAN号, 然后进入 vlan 配置状态,可以输入一个新的 VLAN号或旧的来进行修改。

3 name vlan-name ( 可选) 输入一个 VLAN名,如果没有配置 VLAN名,缺省的名字是 VLAN号前面用 0 填满的 4位数,如 VLAN0004是 VLAN4的缺省名字

4 mtu mtu-size ( 可选) 改变 MTU大小

5 end 退出

6 show vlan { name vlan-name | id vlan-id }

验证

7 copy running-config  startup config ( 可选) 保存配置用

no vlan name 或 no vlan mtu 退回到缺省的 vlan 配置状态

举例如下 :

Switch# configure terminal

Switch(config)# vlan 20

Switch(config-vlan)# name test20

Switch(config-vlan)# end

也可以在 enable 状态下,进行 VLAN配置:

1 vlan database 进入 VLAN配置状态

2 vlan vlan-id name vlan-name 加入 VLAN号及 VLAN名

3 vlan vlan-id mtu mtu-size ( 可选) 修改 MTU大小

4 exit 更新 VLAN数据庫并退出

5 show vlan { namevlan-name | id vlan-id } 验证配置

6 copy running-config startup config 保存配置(可选)

举例如下:

Switch# vlan database

Switch(vlan)# vlan 20 name test20 Switch(vlan)# exit

APPLY completed.

Exiting....

Switch#

2.2.2 删除 VLAN

当删除一个处于 VTP 服务器的交换机上删除 VLAN 时,则此 VLAN 将在所有相同 VTP 的交换机上删除。当在透明模式下删除时,只在当前交换机上删除。

1 configure terminal 进入配置状态

2 no vlan vlan-id 删除某一 VLAN.

3 end 退出

4 show vlan brief 验证

5 copy running-config startup config 保存

也可用 vlan database 进入 VLAN配置状态,用 no vlan vlan-id 来删除。

2.2.3 将端口分配给一个 VLAN

1 configure terminal 进入配置状态

2 interface interface-id 进入要分配的端口

3 switchport mode access 定义二层口

4 switchport access vlan vlan-id 把端口分配给某一 VLAN

5 end 退出Step

6 show running-config interface interface-id 验证端口的 VLAN号

7 show interfaces interface-id switchport 验证端口的管理模式和VLAN情况

8 copy running-config startup-config 保存配置

举例如下:

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 2

Switch(config-if)# end

Switch#

2.3 配置 VLAN Trunks( 中继接口 )

2.3.1 配置 VLAN Trunks( 中继接口 )

1 configure terminal 进入配置状态

2 interface interface-id 进入端口配置状态

3 switchport trunk encapsulation {isl | dot1q   | negotiate } 配置 trunk 封装 ISL 或 802.1Q 或自动协商

4 switchport mode { dynamic { auto | desirable } | trunk } 配置二层 trunk 模式。

dynamic auto—自动协商是否成为 trunk

dynamic desirable—把端口设置为 trunk 如果对方端口是 trunk, desirable, 或自动模式

trunk—设置端口为强制的 trunk方式, 而不理会对方端口是否为trunk

5 switchport access vlan vlan-id  ( 可选) 指定一个缺省 VLAN, 如果此端口不再是 trunk

6 switchport trunk native  vlan vlan-id 指定 802.1Q native VLAN 号

7 end 退出

8 show interfaces interface-id switchport 显示有关 switchport 的配置

9 show interfaces interface-id trunk 显示有关 trunk 的配置

10 copy running-config startup-config 保存配置

举例:

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# interface fastethernet0/4

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# end

2.3.2 定义 trunk 允许的 VLAN

缺省情况下 trunk 允许所有的 VLAN通过。可以使用 switchport trunk allowed

vlan remove vlan-list 来去掉某一 VLAN

1 configure terminal 进入配置状态

2 interface interface-id 进入端口配置

3 switchport mode trunk 配置二层口为 trunk

4 switchport trunk allowed vlan { add | all | except | remove} vlan-list ( 可选) 配置 trunk 允许的 VLAN.使用 add, all , except , remove关健字

5 end 退出

6 show interfaces interface-id switchport 验证 VLAN配置情况 .

7 copy running-config startup-config 保存配置

回到允许所有 VLAN通过时 , 可用 no switchport trunk allowed vlan 端口配置命令 .

举例如下 :

Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport trunk allowed vlan remove 2

Switch(config-if)# end

2.3.3 配置 Native VLAN (802.1q)

封装 802.1q 的 trunk 端口可以接受带有标签和不带标签的数据流,交换机向native vlan 传送不带标签的数据流,缺省情况下 native VLAN 是 1。

1 configure terminal 进入配置状态

2 interface interface-id 进入配置成 802.1qtrunk 的端口

3 switchport trunk native vlan vlan-id 配置 native VLAN 号

4 end 退出

5 show interfaces interface-id switchport 验证 native VLAN 配置

6 copy running-config startup-config 保存配置

使用 no switchport trunk native vlan 端口配置命令回到缺省的状态

三、 STP的配置

3.1 使用 STP实现负载均衡

负载均衡可以使用流量分流到其它平行的 trunks 上去. 交换机为了避免环路,STP通常是阻断所有端口交换机之间只留一条链路 。使用负载均衡后 , 可以把不同 VLAN的流量分配到不同的 trunk 上。

可以通过配置 STP端口权值 STP路径值来实现负载均衡 . 如果使用 STP端口权值来配置那么二条负载均衡的 trunk 必须联同一交换机上。 使用路径值则即可以联相同的交换机与可以联不同的交换机。

3.2 使用 STP端口权值的负载均衡

当同一台交换机的二个口形成环路时, STP端口权值用来决定那个口是 enable的,那个口是阻断的。 可以通过配置端口权值来决定二对 trunk 各走那些 VLAN,

有较高权值的端口(数字较小的) vlan, 将处于转发状态,同一个 VLAN在另一个 trunk 有较低的权值 (数字较大) 则将处在阻断状态。 即同一 VLAN只在一个trunk 上发送接受。

基于端口权值的负载均衡示意图trunk1 将发送和接收 VLAN8-10 的数据,trunk2 将发送和接收 VLAN3-6 的数据

配置如下:

configure terminal 进入 Switch 1 配置状态

vtp domain domain-name 配置 VTP域

vtp mode server 将 Switch 1 配置成 VTP server.

end 退出

show vtp status 验证 VTP的配置

show vlan 验证 VLAN

configure terminal 进入配置状态

interface fastethernet 0/1 进入 F0/1 端口

switchport trunk encapsulation {isl | dot1q | negotiate } 配置 trunk 封装

switchport mode trunk 配置成 trunk

end 退出

show interfaces fastethernet0/1 switchport 验证 VLAN配置

在 switch1 上的 F0/2 上重复 7到 11 步骤

在 Switch 2 的 F0/1,F0/2 上重复 7 到 11 步骤。

show vlan 当 trunk 已经起来,在switch2 上验证已经学到相关的 vlan 配置

configure terminal 在 Switch 1 上进入配置状态

interface fastethernet0/1 进入要配置的端口

spanning-tree vlan 8 port-priority 10将端口权值 10 赋与 VLAN 8.

spanning-tree vlan 9 port-priority 10将端口权值 10 赋与 VLAN 9.

spanning-tree vlan 10 port-priority 10将端口权值 10 赋与 VLAN 10.

exit 退回.

interface fastethernet0/2 进入 F0/2

spanning-tree vlan 3 port-priority 10将端口权值 10 赋与 VLAN 3.

spanning-tree vlan 4 port-priority 10将端口权值 10 赋与 VLAN 4.

spanning-tree vlan 5 port-priority 10将端口权值 10 赋与 VLAN 5.

spanning-tree vlan 6 port-priority 10将端口权值 10 赋与 VLAN 10.

end 退出

show running-config 验证配置

copy running-config 保存配置startup-config

3.3 配置 STP路径值的负载均衡

也可以通过配置配置 STP 路径值来实现负载均衡,如下图所示

Trunk1 走 VLAN8 -10, Trunk2 走 VLAN2 -4

1 configure terminal 进入 Switch 1 配置状态

2 interfa ce fastethernet 0/1 进入 F0/1

3 switchport trunk  encapsulation  { isl | dot1q | negotiate } 配置封装

4 switchport mode trunk 配置 Trunk, 缺省是 ISL 封装

5 exit 退回

6 在 F0/2 口上重复 2-4 步骤

7 end 退出

8 show running-config 验证配置Step 9 show vlan 验证 switch1 已经学到 Vlan

10 configure terminal 进入配置状态

11 interface fastethernet 0/1 进入 F0/1

12 spanning-tree vlan 2 cost 30 设置 Vlan2 生成树路径值为 30

13 spanning-tree vlan 3 cost 30 设置 Vlan3 生成树路径值为 30

14 spanning-tree vlan 4 cost 30 设置 Vlan4 生成树路径值为 30

15 end 退出

16 在 switch1 的 F0/2 上重复 9-11

步骤设置 VLAN8,9,10 生成树路径值为 30

17 exit 退出

18 show running-config 验证配置

19 copy running-config

startup-config

保存配置

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值