poj 3253 Fence Repair 【huffman树 贪心】

Fence Repair

Time Limit: 2000MS

 Memory Limit: 65536K
Total Submissions: 30428 Accepted: 9845

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题目意思:

有一个农夫要把一个木板钜成几块给定长度的小木板,每锯一次都要收取一定费用,这个费用就是当前锯掉的木板长度

给出n个木板及其各自的长度,求最小费用。


看了下面的Hint才理解,huffman裸题,直接优先队列,结果WA,看了看数据过大,全改为long long 才过。。。


huffman:ans记录最小花费,每次取队列里最小的两个值,出队后,ans累加两个数的和,再将两数之和进队列,直到队列只有1个元素为止。最后的ans就是最小花费。


15ms:


#include <cstdio>
#include <queue>
#include <vector> 
#include <algorithm>
#define MAX 20000+10
#define LL long long
using namespace std;
int a[MAX];
LL ans;//最小花费 
priority_queue<LL, vector<LL>, greater<LL> > Q;//小的优先 
void huffman()
{
	LL a, b, c;//这里坑死了 
	while(Q.size() != 1)//只有一个元素为止 
	{
		a = Q.top();//取最小的值 
		Q.pop();
		b = Q.top();//取最小的值 
		Q.pop();
		c = a + b;//求和 
		ans += c;//结果累加 
		Q.push(c);//进队列 
	}
	Q.pop();
}
int main()
{
	int n;//木板个数 
	int i, j;
	while(scanf("%d", &n) != EOF)
	{
		for(i = 0; i < n; i++)
		{
			scanf("%d", &a[i]);
			Q.push(a[i]);//进队列 
		}
		ans = 0; 
		huffman(); 
		printf("%lld\n", ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值