zoj 2770 Burn the Linked Camp 【差分约束】


Burn the Linked Camp

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations


第一道差分约束。


题目意思:刘备有n个兵营,每个兵营都有一个容量即住的最大人数。现在陆逊通过观察得到m条信息,从兵营 i 到 j 的最少人数。 问你能否求出刘备兵营里面的最少人数。能的话输出最少人数,不能输出Bad Estimations。


准备工作:dist[i]记录源点到i的最短路 man[i]表示i营地人数容量  total[i]表示前i个营地总容量


思路:在m条信息里面,我们用 first, last, v分别表示开始营地 结束营地 以及两个营地之间最少人数 ,并设第i个营地实际人数为Ai, 前i个营地实际总人数为Si
          那么可以得到以下3个关系:
          一:第first到第last营地实际人数不小于v s[last] - s[first-1] >= v 可以得到 s[first-1] - s[last] <= -v;
          二:连续营地实际人数不大于营地容量 s[last] - s[first-1] <= total[last] - total[first-1]; 
          三:每个营地实际人数Ai不超过容量且不小于0 ----->   0 <= s[i] - s[i-1] <= man[i];  


问题转化:建图后就是求S[n] - S[0] >= ans即  S[0] - S[n] <= -ans ,我们以n为源点,这里-ans就为 n到0的最短路的相反数 即-dist[0]。




代码实现:


#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAXN 1000+10
#define MAXM 20000+2000+10 //最多边数 
#define INF 1000000000
using namespace std;
struct Edge
{
	int from, to, val, next; 
}edge[MAXM];
int head[MAXN], top;
int dist[MAXN];//dist[i]:源点到i的最短路 
int man[MAXN];//man[i]表示i营地人数容量  
int total[MAXN];//表示前i个营地总容量 
bool vis[MAXN];
int used[MAXN];//判断某点入队次数 
int n, m;//n个营地 m个限制 
void init()
{
	top = 0;
	for(int i = 0; i <= n; i++)
	{
		head[i] = -1;
		used[i] = 0;
		vis[i] = false;
	} 
}
void addedge(int u, int v, int w)
{
	Edge E = {u, v, w, head[u]};
	edge[top] = E;
	head[u] = top++;
}
bool SPFA()
{
	for(int i = 0; i <= n; i++)
	dist[i] = i==n ? 0 : INF; 
	queue<int> Q;
	Q.push(n);//n为源点 
	vis[n] = true;
	used[n]++;
	while(!Q.empty())
	{
		int u = Q.front();
		Q.pop();
		vis[u] = false;//去掉标记 
		for(int i = head[u]; i != -1; i = edge[i].next)
		{
			Edge E = edge[i];
			if(dist[E.to] > dist[u] + E.val)
			{
				dist[E.to] = dist[u] + E.val;
				if(!vis[E.to])
				{
					vis[E.to] = true;
					used[E.to]++;
					if(used[E.to] > n)
					return false;//存在负环 无解 
					Q.push(E.to); 
				}
			}
		} 
	}
	return true;//找到最短路 
} 
void getMap()
{
	int first, last, v;//开始营地 结束营地 以及两个营地之间最少人数 
	/*
	我们设第i个营地实际人数为Ai, 前i个营地实际总人数为Si
	那么可以得到以下3个关系:
	一:第first到第last营地实际人数不小于v s[last] - s[first-1] >= v 可以得到 s[first-1] - s[last] <= -v;
	二:连续营地实际人数不大于营地容量 s[last] - s[first-1] <= total[last] - total[first-1];  
	三:每个营地实际人数Ai不超过容量且不小于0 ----->   0 <= s[i] - s[i-1] <= man[i];  
	*/ 
	man[0] = 0; total[0] = 0; 
	for(int i = 1; i <= n; i++)
	{
		scanf("%d", &man[i]);//第i个营地容量 
		total[i] = man[i];
		addedge(i-1, i, man[i]);
		addedge(i, i-1, 0);//反向边为0 
		total[i] += total[i-1];//统计前i个营地容量 
    }
	while(m--)
	{
		scanf("%d%d%d", &first, &last, &v);//从营地s到营地e最少人数 
		addedge(last, first-1, -v);
		addedge(first-1, last, total[last]-total[first-1]);
	}
}
int main()
{
	while(scanf("%d%d", &n, &m) != EOF)
	{
		init();
		getMap();
		if(SPFA())
		printf("%d\n", -dist[0]);
		else
		printf("Bad Estimations\n");
	}
	return 0;
} 






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值