ZOJ2770:Burn the Linked Camp(差分约束)

Burn the Linked Camp

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations


Author:  ZHOU, Yuan
Source:  ZOJ Monthly, October 2006

题意:N个数的数组,每个数有一个最大值,M个关系,输入a,b,c表示下标a到b的和大于等于c,问这N个数的和最小值是什么,条件不合理就输出-1.

思路:Sb-Sa>=c,则Sa-Sb<=-c这里建边,同时每个数最大值Si-Si-1<=num建边,正向也要建边,因为我们最终要求0到n的最短路,又每个数都>=0,所以Si-1 - Si <=0建边,跑最短路判负环即可。

# include <iostream>
# include <cstdio>
# include <cstring>
using namespace std;
typedef long long LL;
const int maxn = 1e4+3;
struct node
{
    int e, w, next;
}edge[maxn<<4];
int n, m, Next[maxn], tot, vis[maxn], q[maxn<<6], in[maxn];
LL sum[maxn], dis[maxn];
void add_edge(int u, int v, int w)
{
    edge[tot] = node{v, w, Next[u]};
    Next[u] = tot++;
}
inline int Scan()
{
    int res=0,ch,flag=0;
    if((ch=getchar())=='-')
        flag=1;
    else if(ch>='0'&&ch<='9')
        res=ch-'0';
    while((ch=getchar())>='0'&&ch<='9')
        res=res*10+ch-'0';
    return flag?-res:res;
}
inline void Out(LL a)
{
    if(a>9) Out(a/10);
    putchar(a%10+'0');
}
LL spfa()
{
    for(int i=0; i<=n; ++i) dis[i] = 1e18, vis[i] = in[i] = 0;
    int r=0;
    q[r++] = 0;
    vis[0] = 1;
    dis[0] = 0;
    while(r)
    {
        int u = q[--r];
        vis[u] = 0;
        for(int i=Next[u]; i!=-1; i=edge[i].next)
        {
            int v = edge[i].e, w =edge[i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(!vis[v])
                {
                    vis[v] = 1;
                    q[r++] = v;
                    if(++in[v] > n+1) return -1;
                }
            }
        }
    }
    return dis[n];
}
int main()
{
    int a, b, c;
    while(~scanf("%d%d",&n,&m))
    {
        tot = 0;
        memset(Next, -1, sizeof(Next));
        for(int i=1; i<=n; ++i) sum[i] = Scan();
        for(int i=1; i<=n; ++i)
        {
            add_edge(i, i-1, sum[i]);
            add_edge(i-1, i, 0);
        }
        while(m--)
        {
            a = Scan(), b = Scan(), c = Scan();
            add_edge(a-1, b, -c);
        }
        LL ans = spfa();
        if(ans == -1) puts("Bad Estimations");
        else
            Out(-ans), puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值