Burn the Linked Camp ZOJ - 2770(差分约束系统)

题目

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei’s wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called “Linked Camps”.

Let’s go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1…n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei’s troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei’s Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei’s army from Lu Xun’s observation. However, Lu Xun’s estimations given in the input data may be very unprecise. If his estimations cannot be true, output “Bad Estimations” in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations

解释

由题意可以得到多个不等式关系,设前n个军营总人数为Sn,单个军营人数为Ai。
题目告知每个军营的人数不超过Ci。0 <= Ai <= Ci Ai = Si -Si-1 由此左右两边得出两组不等式关系,不等式关系换号两边同乘以-1,使得两组不等式关系同向,转化为图上单源最短路问题的三角不等式,题目又给出信息i到j营的人数至少有
w, 由此得到关系 Sj - Si-1 >= w ,则Si-1 - Sj <= -w。三组不等式关系建立图,存边,然后借助bellmanford求最短路,Si为图上点。
题目求的是所有营最少有多少人M,即Sn - S0 >= M, S0 -Sn <= -M,由图上单源最短路问题的三角不等式,题目所求结果转化为求Sn到S0的最短路径长度结果乘上-1,所以将Sn设为起点。结果为 d[n] -d[0],由于d[n]等于0,相当于是-d[0]。

#include <cstdio>
#include <vector>
int const inf = 0x3f3f3f3f;
#define maxn 1001
using namespace std;
int n, m;
struct Edge {
	int u, v, w;
	Edge(int _u, int _v, int _w) :u(_u), v(_v), w(_w) { }
};
vector <Edge> e;
int d[maxn];
int bellman_ford() {
	for (int i = 0; i <= n; i++)
		d[i] = inf;
	d[n] = 0;
	int flag = 1;
	for (int i = 0; i < n&& flag; i++) {
		flag = 0;
		for (int j = 0; j <(int)e.size(); j++) {
			if (d[e[j].v] > d[e[j].u] + e[j].w) {
				d[e[j].v] = d[e[j].u] + e[j].w;
				flag = 1;
			}
		}
	}
	if (!flag) return 0;
	else {

		for (int j = 0; j < (int)e.size(); j++) {
			if (d[e[j].v] > d[e[j].u] + e[j].w) {
				d[e[j].v] = d[e[j].u] + e[j].w;
				return 1;
			}
		}
		return 0;
	}
}
int s[1001];
int main() {
	int c;
	int u, v, w;
	while (~scanf("%d %d", &n, &m)){
		e.clear();
		s[0] = 0;
		for (int  i = 1; i <= n; i++){
			scanf("%d", &c);
			e.push_back(Edge(i - 1, i, c));
			e.push_back(Edge(i, i - 1, 0));
			s[i] = c + s[i - 1];
		}
		for (int j = 0; j < m; j++) {
			scanf("%d %d %d", &u, &v, &w);
			e.push_back(Edge(v, u-1, -w));
		}
		if (bellman_ford()) printf("Bad Estimations\n");
		else printf("%d\n", d[n] - d[0]);//等效于-d[0]
	}



	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值