HDU-2844 Coins (多重背包+优化)

Coins

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题目大意:有n种硬币,价值为A1 A2.....An,数量为C1 C2 ........Cn,问这些硬币能组成几个小于等于m的数

思路:多重背包,求出容量为1-m的背包能装的最大价值,如果dp[i]==i 说明能组成 i,这样就转化为了裸的多重背包,但是算一下复杂度发现时间回超,所以枚举背包数量的那一层要想办法优化,可以用二进制优化,具体看代码的实现

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int v[105],c[105],dp[100005];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            scanf("%d",&v[i]);
        for(int i=1; i<=n; i++)
            scanf("%d",&c[i]);
        for(int i=1; i<=n; i++)
        {
            for(int k=1; k<=c[i]; k<<=1)
            {
                for(int j=m; j>=k*v[i]; j--)
                {
                    dp[j]=max(dp[j],dp[j-k*v[i]]+v[i]*k);
                }
                c[i]-=k;
            }
            if(c[i]>0)
                for(int j=m; j>=c[i]*v[i]; j--)
                    dp[j]=max(dp[j],dp[j-c[i]*v[i]]+c[i]*v[i]);
        }
        int ans=0;
        for(int i=1; i<=m; i++)
            //printf("%d %d\n",i,dp[i]);
        if(dp[i]==i) ans++;
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值