POJ-1330 Nearest Common Ancestors (离线Tarjan | 倍增算法)

Nearest Common Ancestors

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 
 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

题目大意:t组输入,给出n和有n个节点的树,n-1行的u,v 表示u是v父节点,最后一行u v ,求u,v的最近公共祖先

思路:只有一个查询,在线离线都可以实现

 

离线Tarjan代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
const int N=10005;
int first[N],first1[N],tot,tot1;
int fa[N],vis[N],isroot[N],ans[N],n;
struct node
{
    int v,nex;
}e[N<<1];
struct query
{
    int v,nex,id;
}q[N<<1];
void adde(int u,int v)
{
    e[tot].v=v;
    e[tot].nex=first[u];
    first[u]=tot++;
}
void addee(int u,int v,int id)
{
    q[tot1].v=v;
    q[tot1].nex=first1[u];
    q[tot1].id=id;
    first1[u]=tot1++;
}
void init()
{
    tot=tot1=0;
    mem(first,-1);
    mem(first1,-1);
    mem(vis,0);
    mem(ans,0);
    mem(isroot,1);
}
int find(int x)
{
    if(fa[x]==x) return x;
    return fa[x]=find(fa[x]);
}
void LCA(int u,int pre)
{
    for(int i=first[u];~i;i=e[i].nex)
    {
        int v=e[i].v;
        if(v==pre) continue;
        if(!vis[v])
        {
            LCA(v,u);
            fa[v]=u;
        }
    }
    vis[u]=1;
    for(int i=first1[u];~i;i=q[i].nex)
    {
        int v=q[i].v;
        if(vis[v])
        {
            int id=q[i].id;
            ans[id]=find(v);
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d",&n);
        for(int i=1;i<=n;i++) fa[i]=i;
        int a,b,root;
        for(int i=1;i<n;i++) //存树
        {
            scanf("%d%d",&a,&b);
            adde(a,b);
            adde(b,a);
            isroot[b]=0;
        }
        scanf("%d%d",&a,&b); //存查询
        addee(a,b,1);
        addee(b,a,1);
        for(int i=1;i<=n;i++) //判根节点
            if(isroot[i])
            {
                root=i;
                break;
            }
        LCA(root,fa[root]); 
        printf("%d\n",ans[1]);
    }
    return 0;
}

 

倍增算法:

预处理得到所有节点向上走2^i 步所到达的节点p[x][i],预处理通过p[x][i]=p[p[x][i-1]][i-1]实现,先让v走到与u同一深度的位置,再让u,v一起向上走

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
const int N=10005;
int fa[N],d[N],p[N][21];
int first[N],tot,n;
struct node
{
    int v,nex;
}e[N<<1];
void adde(int u,int v)
{
    e[tot].v=v;
    e[tot].nex=first[u];
    first[u]=tot++;
}
void init()
{
    tot=0;
    mem(p,0);
    mem(first,-1);
    mem(d,0);
    mem(fa,0);
}
void dfs(int u,int pre)
{
    d[u]=d[pre]+1;
    p[u][0]=pre;
    for(int i=1;(1<<i)<=d[u];i++)
        p[u][i]=p[p[u][i-1]][i-1];
    for(int i=first[u];~i;i=e[i].nex)
    {
        int v=e[i].v;
        if(v!=pre) dfs(v,u);
    }
}
int LCA(int u,int v)
{
    if(d[u]>d[v]) swap(u,v);
    int tmp=d[v]-d[u];
    for(int i=20;i>=0;i--)
        if((1<<i)&tmp)
        v=p[v][i];
    if(u==v) return u;
    for(int i=20;i>=0;i--)
    {
        if(p[u][i]==p[v][i]) continue;
        else u=p[u][i],v=p[v][i];
    }
    return p[u][0];
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d",&n);
        int u,v,root;
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            adde(u,v);
            adde(v,u);
            fa[v]=u;
        }
        for(int i=1;i<=n;i++)
            if(fa[i]==0)
        {
            root=i;
            break;
        }
        dfs(root,0);
        scanf("%d%d",&u,&v);
        printf("%d\n",LCA(u,v));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值