L2-002 链表去重

37 篇文章 0 订阅
22 篇文章 0 订阅
文章描述了一个C++编程问题,要求从给定的整数键值链表中删除绝对值重复的节点,保留第一个出现的节点,并将删除的节点存储到另一个链表中。展示了如何使用unordered_map数据结构实现这个功能。
摘要由CSDN通过智能技术生成

给定一个带整数键值的链表 L,你需要把其中绝对值重复的键值结点删掉。即对每个键值 K,只有第一个绝对值等于 K 的结点被保留。同时,所有被删除的结点须被保存在另一个链表上。例如给定 L 为 21→-15→-15→-7→15,你需要输出去重后的链表 21→-15→-7,还有被删除的链表 -15→15。

输入格式:

输入在第一行给出 L 的第一个结点的地址和一个正整数 N(≤105,为结点总数)。一个结点的地址是非负的 5 位整数,空地址 NULL 用 -1 来表示。

随后 N 行,每行按以下格式描述一个结点:

地址 键值 下一个结点

其中地址是该结点的地址,键值是绝对值不超过104的整数,下一个结点是下个结点的地址。

输出格式:

首先输出去重后的链表,然后输出被删除的链表。每个结点占一行,按输入的格式输出。

输入样例:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

输出样例:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

代码:

#include <iostream>
#include <unordered_map>

using namespace std;

const int N = 1e5 + 10;

unordered_map<int, int> dedup_hash;
unordered_map<string, int>h;
string head;
int n;
struct node {
    string head, end;
    int num;
}nodes[N], dedup[N], del[N];

int main() {
    cin  >> head >> n;
    for (int i = 0; i < n; i ++ ) {
        cin >> nodes[i].head >> nodes[i].num >> nodes[i].end;
        h[nodes[i].head] = i;
    }
    string l = head, r = "-1";
    int l_cnt = 0, r_cnt = 0;
    int root = h[head];
    while(1) {
        if (!dedup_hash[abs(nodes[root].num)]) {
            dedup_hash[abs(nodes[root].num)] = 1;
            if (l_cnt != 0) dedup[l_cnt - 1].end = nodes[root].head;
            dedup[l_cnt].head = nodes[root].head;
            dedup[l_cnt].num = nodes[root].num;
            l_cnt ++ ;
        }
        else {
            if (r_cnt != 0) del[r_cnt - 1].end = nodes[root].head;
            del[r_cnt].head = nodes[root].head;
            del[r_cnt].num = nodes[root].num;
            r_cnt ++ ;
        }
        if (nodes[root].end == "-1") break;
        root = h[nodes[root].end];
    }
    for (int i = 0; i < l_cnt; i ++ ) {
        if (i == l_cnt - 1) cout << dedup[i].head << ' ' << dedup[i].num << ' ' << "-1" << endl;
        else cout << dedup[i].head << ' ' << dedup[i].num << ' ' << dedup[i].end << endl;
    }
    for (int i = 0; i < r_cnt; i ++ ) {
        if (i == r_cnt - 1) cout << del[i].head << ' ' << del[i].num << ' ' << "-1" << endl;
        else cout << del[i].head << ' ' << del[i].num << ' ' << del[i].end << endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值