poj1852_Ants(弹性碰撞问题)

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207
题意:n只蚂蚁以每秒1cm的速度在长为L的杆子上爬行。当蚂蚁爬到杆子的端点时就会掉落。由于杆子太细,两只蚂蚁相遇时,它们不能交错通过,只能各自反向爬回去。对于每只蚂蚁,我们知道它距离杆子左端的距离xi,但不知道它当前的朝向。请计算所有蚂蚁落下杆子所需要的最短时间和最长时间。
分析:对于最短时间,所有蚂蚁都朝向离竿子端点进的一端走,这种情况下不会发生相遇。所以找最短时间,要保证所有的蚂蚁全部落下杆子,即所有蚂蚁下落的最大的最小时间。。。。而对于最长时间,当两只蚂蚁相遇时,若将两只蚂蚁分别编号1,2,则他们会分别向相反的方向爬行,但如果两只蚂蚁没有编号区别,当向相反的方向走时,可以认为是保持原样交错通过。这样便可认为每只蚂蚁都是独立运动的,所以要求最长的时间,只要求蚂蚁到竿子端点的最大距离即可。
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
#define Max 1000100
using namespace std;
int L;
int n;
int x[Max];
void solve()
{
    int maxt = 0,mint = 0;
    int maxx = 0;
    //最长时间(只求蚂蚁到杆子端点的最大距离就好)
    for(int i=1;i<=n;i++)
    {
        maxx = max(x[i],L-x[i]);  //一只蚂蚁到杆子两端的最大距离
        if(maxx > maxt)  //找出所有蚂蚁中最大的距离
            maxt = maxx;
    }
    //最短时间
    for(int i=1;i<=n;i++)
    {
        /*能够使得全部蚂蚁下去的最短时间,不能只单纯的找出最短时间,还要保证全部蚂蚁下去,所以要找能够让蚂蚁全部下去的最短时间里面最大的时间*/
        mint =max(mint, min(x[i],L-x[i]));
    } 
    printf("%d %d\n",mint,maxt);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&L,&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&x[i]);
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值