HDOJ 3613 Best Reward

本来想练EX_KMP的,一读题发现是回文串,与回文串有关的一定要用神器manacher啊!!!然后就用manacher写了。。

manacher出所有的回文串半径,然后预处理一遍,最后统计最大值。从左边延续过来的回文串,要看右边有没有构成回文,反之亦然。。。

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 505    Accepted Submission(s): 203


Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000. 

 

Output
Output a single Integer: the maximum value General Li can get from the necklace.
 

Sample Input
  
  
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac
 

Sample Output
  
  
1 6
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=550000;
const int INF=0x3f3f3f3f;

char str[maxn],ans[maxn*2];
int p[maxn*2],table[30],sum[maxn*2];
int pal[maxn*2],par[maxn*2];

void pre()
{
    int tot=1;
    memset(ans,0,sizeof(ans));
    ans[0]='$';
    int len=strlen(str);
    for(int i=0;i<len;i++)
    {
        ans[tot]='#'; tot++;
        ans[tot]=str[i]; tot++;
    }
    ans[tot]='#';
}

void manacher()
{
    pre();
    memset(p,0,sizeof(p));
    int len=strlen(ans);
    int mid=-1,mx=-1;
    for(int i=0;i<len;i++)
    {
        int j=-1;
        if(i<mx)
        {
            j=2*mid-i;
            p[i]=min(p[j],mx-i);
        }
        else p[i]=1;

        while(i+p[i]<len&&ans[i+p[i]]==ans[i-p[i]]) p[i]++;

        if(p[i]+i>mx)
        {
            mx=p[i]+i;mid=i;
        }
    }
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
while(T_T--)
{
    for(int i=0;i<26;i++) scanf("%d",table+i);
    scanf("%s",str);
    manacher();
    sum[0]=0;
    int sz=strlen(ans);
    for(int i=1;i<sz;i++)
    {
        sum[i]=sum[i-1];
        if(ans[i]>='a'&&ans[i]<='z')
        {
            sum[i]+=table[ans[i]-'a'];
        }
    }
    ans[1]='$'; ans[sz-1]='$';
    int ret=-INF;
    memset(pal,0,sizeof(pal));
    memset(par,0,sizeof(par));
    for(int i=2;i<sz;i++)
    {
        int r=p[i]-1;
        int L=i-r,R=i+r;
        if(ans[L]=='$'&&ans[R]=='$') continue;///必须要割两段
        if(ans[L]=='$')
        {
            ///后一半可能是回文串,要把结果记录到右端点去
            par[R]=sum[R];
            if(!(ans[R]>='a'&&ans[R]<='z')) par[R-1]=sum[R];
            else par[R+1]=sum[R];
        }
        else if(ans[R]=='$')
        {
            ///前一半可能是回文串,要把结果记录到左端点去
            int temp=sum[R]-sum[L-1];
            pal[L]=temp;
            if(!(ans[L]>='a'&&ans[L]<='z')) pal[L+1]=temp;
            else pal[L-1]=temp;
        }
    }
    ///统计答案
    for(int i=2;i<sz;i++)
    {
        int r=p[i]-1;
        int L=i-r,R=i+r;
        if(ans[L]=='$'&&ans[R]=='$') continue;///必须要割两段

        if(ans[L]=='$')
        {
            ret=max(ret,sum[R]+pal[R+1]);
        }
        else if(ans[R]=='$')
        {
            int temp=sum[R]-sum[L-1];
            ret=max(ret,temp+par[L-1]);
        }
        else ret=max(0,ret); ///当存在负数值的时候0可能是最大的
    }
    printf("%d\n",ret);
}
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值