poj1704 Georgia and Bob------P/N分析

Georgia and Bob
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 5821Accepted: 1637

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source

 
 
题意:给一个1*M的棋盘,上面有N颗棋子,每次只能向左移动棋子,并且至少移动一步,两人轮流操作,谁不能移动谁就输了。
分析这题的P/N点时,和往常不一样,不是从小数据推测,而是直接从性质推测,从右往左,把棋子分为两两一组,如果是奇数颗棋子,就补第一颗的位置为0,当对手移动两颗棋子的左边的棋子时,我们只需要把右边这颗棋子移动相同的步数就行,当对手移动右边的棋子时,把两颗棋子之间的距离看为石子的个数,我们只需按照取石子的规则走就行。
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[1010];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
        int ans=0;
        sort(a,a+n);
        if(n&1)
        {
            ans^=(a[0]-1);
            for(int i=2;i<n;i+=2)
            ans^=(a[i]-a[i-1]-1);
        }
        else
        for(int i=1;i<n;i+=2)
        ans^=(a[i]-a[i-1]-1);
        //cout<<ans<<endl;
        if(ans!=0)
        puts("Georgia will win");
        else
        puts("Bob will win");
    }
}
/*
3
3
1 2 3
8
1 5 6 7 9 12 14 17
Bob will win
Georgia will win
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值