C - Number Sequence POJ - 1019 (递归)

C - Number Sequence

 POJ - 1019 

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=225;
const int mmax = 40200+ 7;
long long len[mmax],sum[mmax];
void init() //打表
{
   len[0]=0;
   sum[0]=0;
   //分段 1 12 123 1234 …… 123456891011
   for(int i=1;i<mmax;i++){
      len[i]=len[i-1]+(int)log10((double)i)+1; //第i段
      sum[i]=sum[i-1]+len[i];       //加入第i段后的整个长度
   }
}
int solve(int n){
int k=0;
while(sum[k]<n) //能覆盖n的最长序列
      k++;
int lastn=n-sum[k-1];  //去掉完全段后的剩余部分
int len_n=0;
int t=1;
while(len_n<lastn){  //求残余部分在第k段的位置
      len_n+=(int)log10((double)t)+1;
      t++;
}
int num=len_n-lastn;
return (t-1)/(int)pow((double)10,(double)num)%10;  
//pow原型为:double pow(double x, double y);
}
int main()
{
    init();
    int t;
    cin>>t;
    int n;
    while(t--){
      scanf("%d",&n);
      printf("%d\n",solve(n));
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值