poj1019:Number Sequence

题目:

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24168 Accepted: 6466
Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output

There should be one output line per test case containing the digit located in the position i.
Sample Input

2
8
3
Sample Output

2
2
Source

Tehran 2002, First Iran Nationwide Internet Programming Contest

每一层的数字当上升的二位数或者三位数的时候,一个数字就增加2位或着三位,所以要利用公式:(int)log10((double)i)+1 求i的位数
还应该注意要打表,要不然会超时

代码:

#include<iostream>
#include<math.h>
using namespace std;
typedef long long ll;
ll a[100005],s[100005]; //a[i] 第i层有多少个 //s[i] 到i层总共有多少个
void reset() //打表
{
    a[1] = 1;
    s[1] = 1;
    for(ll i = 2; i < 65536; i++)
    {
        a[i] = a[i - 1] + (ll)log10((double)i)+1; //(int)log10((double)i)+1  i有多少位
        s[i] = s[i - 1] + a[i]; 
        //cout << s[i] << endl;
    }
}
int main()
{
    ll t;
    cin >> t;
    reset();
    while(t--)
    {
        ll x;
        cin >> x;
        ll i = 1;
        while(s[i] < x)
        {
            //cout << "s[i] " << s[i] << endl;
            i++;
        }// i就是第几层上面
        //cout << "i = " << i << endl;
        ll pos = x - s[i - 1];
        ll tmp = 0;
        for(i = 1; tmp < pos; i++)
        {
            tmp += (ll)log10(double(i)) + 1;
        }
        ll k = tmp - pos;
        i--;
        ll m = i / pow(10, k);
        m %= 10;
        cout << m << endl;
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值