ACM: poj 第50题 一题递推数论题  …

 

                                                           Number Sequence

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

283

Sample Output

22 题意: 给你一个序号, 找出在序列 11212312341234512345612345671234567812345678912345678910123456789101112345678910...中是什么.

 思路:

      1. 先确定每个子串的长度: 123...i的长度是啊a[i-1], 123...ii+1的长度a[i] = a[i-1]+1;

      2. 由1可以看出后一个子串的长度是前一个子串的长度+1.

      3. 其实+1是不准确, 应该是a[i] = a[i-1] + (int)log10(1.0*i) + 1;

      4. 确定位置: b[i] = b[i-1] + a[i-1]; (前一个子串的长度+位置 = 后一个子串的位置)

 

 代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
#define MAX 35000

int a[MAX];
__int64 b[MAX];
int result[200000];

void init()
{
    int i;
    a[0] = 0;
    a[1] = 1;
    for(i = 2; i < MAX; ++i)
    {
        a[i] = a[i-1] + (int)log10(1.0*i) + 1;
    }

    b[0] = 1;
    for(i = 1; i < MAX; ++i)
    {
        b[i] = b[i-1] + a[i-1];
    }
}

void list()
{
    int i , j , k;
    int num = 1;
    for(i = 1; i < MAX; ++i)
    {
        int ans[22];
        k = 0;
        for(j = i; j != 0; j /= 10)
        {
            ans[k] = j % 10;
            ++k;
        }

        while(k--)
        {
            result[num] = ans[k];
            ++num;
        }
    }
}


int main()
{
    init();
    list();

    int n;
    cin >> n;
    while(n--)
    {
        int i;
        int num;
        cin >> num;
        for(i = 1; i < MAX; ++i)
        {
            if(num <= b[i])
                break;
        }

        if(num == b[i])
            cout << "1" << endl;
        else
        {
            cout << result[num-b[i-1]+1] << endl;
        }
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值