POJ 3009 - Curling 2.0(深搜)

11 篇文章 0 订阅

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8930 Accepted: 3762

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1


============================

就是一种小游戏……

从2开始;

只能横竖方向走;

如果石头是静止的时候可以任意选择一个旁边没有障碍的方向扔出去;

除非碰到障碍物否则会一直运动下去;

如果运动的时候碰到障碍物,停止运动,障碍物消失;

如果运动到区域外就失败了;

如果达到终点(3)就成功了;

运动十次以上也算失败。

具体的可以结合题中的图来看


#include <iostream>
#include <cstdio>

using namespace std;

int n,m,startx,starty,endx,endy,minans;
int dir[4][2]={{-1,0},{0,-1},{0,1},{1,0}};
int map[22][22];

bool check(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m) return 1;
    return 0;
}

void dfs(int x,int y,int ans)
{
    if(ans>10) return;//运动次数大于10
    int dx,dy;
    for(int i=0;i<4;i++)
    {
        //cout<<"i="<<i<<endl;
        dx=x+dir[i][0];
        dy=y+dir[i][1];
        if(dx==endx&&dy==endy)
        {
            if(ans<minans) minans=ans;
            return;
        }
        if( map[dx][dy]==1 || (!check(dx,dy)) )//不能朝这个方向前进
        {
            //cout<<"aaaa"<<endl;
            continue;
        }
        while(map[dx][dy]!=1)//如果没有障碍则一直前进
        {
            dx+=dir[i][0];
            dy+=dir[i][1];
            if(dx==endx&&dy==endy)
            {
                if(ans<minans) minans=ans;
                //cout<<"cccc"<<endl;
                return;
            }
            if(!check(dx,dy))
            {
                //cout<<"dddd"<<endl;
                break;
            }
        }
        if(!check(dx,dy)) continue;
        map[dx][dy]=0;//障碍物消失
        dfs(dx-dir[i][0],dy-dir[i][1],ans+1);//注意要退回来搜索
        map[dx][dy]=1;//回溯
    }
}

int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        if(m==0&&n==0) break;
        minans=1e9;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(map[i][j]==2)
                {
                    startx=i;starty=j;
                }
                if(map[i][j]==3)
                {
                    endx=i;endy=j;
                }
            }
        }
        dfs(startx,starty,1);
        if(minans!=1e9) printf("%d\n",minans);
        else printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值