Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 29686 | Accepted: 14001 | |
Case Time Limit: 2000MS |
Description
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Sample Input
6 3 1 7 3 4 2 5 1 5 4 6 2 2
Sample Output
6 3 0
===========================
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#define N 222222
using namespace std;
int num[N],MAX,MIN;
struct Tree
{
int l;
int r;
int max;
int min;
} tree[N*4];
void push_up(int root)
{
tree[root].max=max(tree[root<<1].max,tree[root<<1|1].max);
tree[root].min=min(tree[root<<1].min,tree[root<<1|1].min);
}
void build(int root,int l,int r)
{
tree[root].l=l;
tree[root].r=r;
if(tree[root].l==tree[root].r)
{
tree[root].max=num[l];
tree[root].min=num[l];
return;
}
int mid=(l+r)/2;
build(root<<1,l,mid);
build(root<<1|1,mid+1,r);
push_up(root);
}
void update(int root,int pos,int val)
{
if(tree[root].l==tree[root].r)
{
tree[root].max=val;
tree[root].min=val;
return;
}
int mid=(tree[root].l+ tree[root].r)/2;
if(pos<=mid)
update(root<<1,pos,val);
else
update(root<<1|1,pos,val);
push_up(root);
}
void query(int root,int L,int R,Tree tree[])
{
if(L<=tree[root].l&&R>=tree[root].r)
{
MIN=min(MIN,tree[root].min);
MAX=max(MAX,tree[root].max);
return;
}
int mid=(tree[root].l+tree[root].r)/2;
if(L<=mid) query(root<<1,L,R,tree);
if(R>mid) query(root<<1|1,L,R,tree);
}
int main()
{
int n,q,a,b;
scanf("%d%d",&n,&q);
for(int i=1;i<=n;i++)
{
scanf("%d",&num[i]);
}
build(1,1,n);
for(int i=0;i<q;i++)
{
scanf("%d%d",&a,&b);
MAX=-1;MIN=1e9;
query(1,a,b,tree);
printf("%d\n",MAX-MIN);
}
return 0;
}