UVA 846 - Steps(数学)

 Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers:  0$ \le$x$ \le$y < 231 . For each test case, print a line giving the minimum number of steps to get from  x  to  y .

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4



Miguel Revilla 2002-06-15

==============================

第一步为1,最后一步也为1,连续两步的大小只能相等或相差1,从坐标x走到坐标y,输出最少的步数


因为两边大小是固定的所以大小往中间逐渐加1,如果最后剩下的大小不够一步的话,一定可以调整前面的步子大小使之可以成为一步。这样就是最少的步数


#include <iostream>

using namespace std;

int main()
{
    int t,x,y;
    cin>>t;
    while(t--)
    {
        cin>>x>>y;
        int d=y-x;
        int step=1,ans=0,flag=0;
        while(d>0)
        {
            d-=step;
            ans++;
            if(flag) step++;
            flag=!flag;
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值