UVA 10344 - 23 Out of 5(回溯)

11 篇文章 0 订阅

23 Out of 5

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Your task is to write a program that can decide whether you can find an arithmetic expression consisting of five given numbers (1<=i<=5) that will yield the value 23.
For this problem we will only consider arithmetic expressions of the following from:

 
where : {1,2,3,4,5} -> {1,2,3,4,5} is a bijective function
and  {+,-,*} (1<=i<=4)

Input

The Input consists of 5-Tupels of positive Integers, each between 1 and 50.
Input is terminated by a line containing five zero's. This line should not be processed.

Output

For each 5-Tupel print "Possible" (without quotes) if their exists an arithmetic expression (as described above) that yields 23. Otherwise print "Impossible".

Sample Input

1 1 1 1 1
1 2 3 4 5
2 3 5 7 11
0 0 0 0 0

Sample Output

Impossible
Possible
Possible

=============================

五个数字都用完的时候返回

要注意第一个数字不是固定的,要从五个数中选一个出来


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int ok,a[11];
bool vis[11];

void dfs(int cur,int ans)
{
    if(cur==5)
    {
        if(ans==23)
            ok=1;
        return;
    }
    for(int i=0;i<5;i++)
    {
        if(!vis[i])
        {
            vis[i]=1;
            dfs(cur+1,ans+a[i]);
            dfs(cur+1,ans-a[i]);
            dfs(cur+1,ans*a[i]);
            vis[i]=0;
        }
        if(ok) return;
    }
}

int main()
{
    while(~scanf("%d%d%d%d%d",&a[0],&a[1],&a[2],&a[3],&a[4]))
    {
        if(a[0]==0&&a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0) break;
        ok=0;
        for(int i=0;i<5;i++)
        {
            memset(vis,0,sizeof(vis));
            vis[i]=1;
            dfs(1,a[i]);
        }
        if(ok) printf("Possible\n");
        else printf("Impossible\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值