UVA 10106 - Product(大数乘法)

6 篇文章 0 订阅

Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444

==========================

大数乘大数

pro数组定义成char就不对呢……大概是乘积和超出256了吧0.0


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

int pro[555],lenpro;

void temp(char a[])
{
    int len=strlen(a);
    for(int i=0;i<len/2;i++)
        swap(a[i],a[len-1-i]);
}

void mul(char a[],char b[])
{
    temp(a);
    temp(b);
    int lena=strlen(a);
    int lenb=strlen(b);
    int len;
    for(int i=0;i<lena;i++)
    {
        for(int j=0;j<lenb;j++)
        {
            pro[i+j]+=((a[i]-'0')*(b[j]-'0'));
        }
    }
    /*for(int i=0;i<lena+lenb-1;i++)
        printf("%d ",pro[i]);
    printf("\n");*/
    if(lena>lenb) len=lena+lena;
    else len=lenb+lenb;
    for(int i=0;i<=len;i++)
    {
        pro[i+1]+=pro[i]/10;
        pro[i]=pro[i]%10;
        if(pro[i+1]>0) lenpro=i+2;
    }
    pro[lenpro]='\0';
    for(int i=0;i<lenpro/2;i++)
        swap(pro[i],pro[lenpro-1-i]);
}

int main()
{
    char a[333],b[333];
    while(cin>>a>>b)
    {
        if(a[0]=='0'||b[0]=='0')
        {
            cout<<"0"<<endl;
            continue;
        }
        memset(pro,0,sizeof(pro));
        mul(a,b);
        for(int i=0;i<lenpro;i++)
            cout<<pro[i];
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值