1016 Phone Bills (25 point(s))

1016 Phone Bills (25 point(s))

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

复杂模拟。注意STL的使用、有效记录判断等。

思路:

1. 对于每一条记录,采用结构体record来记录,注意基于时间重载运算符。

2.  对每一位用户分别记录他/她的通话记录,考虑到要按照时间排序,可以利用set本身的排序,使用map<string,set<record> > mp存储。

3. 输入完成后,对于每一位用户的通话记录,判断哪些是有效的(注意迭代器的用法),同时计算分钟数、价格、总价格等。特别注意bill()分别按照每个小时不一样的标准(cents/minute)来计算单笔订单价格。

同类型题:1095 Cars on Campus (30 point(s))

#include<vector>
#include<iostream>
#include<map>
#include<algorithm>
#include<cstring>
#include<set>
using namespace std;
double price[24];//美元/分钟 
double dayPrice=0.0;
struct record{
	int month,day,hour,min,time;string status;
	bool operator < (const record &other) const{
		return time<other.time;
	}
	record(int mon,int d,int h,int m,int t,string s):month(mon),day(d),hour(h),min(m),time(t),status(s){}
};
double bill(int day,int hour,int min){//到1日0时0分的费用 
	double sum = min*price[hour];
	for(int i=0;i<hour;i++) sum+=(price[i]*60);
	return sum+(day-1)*dayPrice*60;
}
map<string,set<record> > mp; 
int main(void){
	for(int i=0;i<24;i++){
		cin>>price[i];
		price[i]=price[i]/100.00;
		dayPrice+=price[i];
	}
	int N;cin>>N;
	string name,status;int mon,day,hour,min;
	for(int i=0;i<N;i++){
		cin>>name;
		scanf("%d:%d:%d:%d",&mon,&day,&hour,&min);
		cin>>status;
		int time = min+hour*60+day*24*60;
		mp[name].insert(record(mon,day,hour,min,time,status));
	}
	map<string,set<record> >::iterator i;
	for(i = mp.begin();i!=mp.end();i++){
		set<record>::iterator j=(i->second).begin();
		set<record>::iterator jnext=(i->second).begin();
		jnext++; 
		bool output = false;
		double sumBill = 0.0;
		for(;j!=(i->second).end()&&jnext!=(i->second).end();j++,jnext++){
			if(j->status=="on-line"&&jnext->status=="off-line"){
				if(!output){
					printf("%s %02d\n",(i->first).c_str(),j->month);
					output = true;	
				}
				printf("%02d:%02d:%02d ",j->day,j->hour,j->min);
				printf("%02d:%02d:%02d ",jnext->day,jnext->hour,jnext->min);
				double thisBill = bill(jnext->day,jnext->hour,jnext->min) - bill(j->day,j->hour,j->min);
				printf("%d $%.2f\n",jnext->time-j->time,thisBill);
				sumBill += thisBill;
			}
		}
		if(output){
			printf("Total amount: $%.2f\n",sumBill);
		}
	}
	return 0;
}

 详细思路:https://blog.csdn.net/richenyunqi/article/details/79307384

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值