1155 Heap Paths (30 point(s))

1155 Heap Paths (30 point(s))

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

考点:输出树的所有路径、堆的判断

注意点:

1. 对于最大堆,任何一个从根到叶子结点的的路径都应该是非递增路径;对于最小堆,任何一个从根到叶子结点的路径都应该是非递减路径,由此可以这个特性在得到路径的过程的时候就进行判断。

2. 关于树的遍历中对vector<int> v的操作。即注意当跳出递归时需要v.pop_back()。

AC代码1(利用特性)

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1007;
int N;
int levelOrder[MAX];
vector<int> v;
bool isMax =true;bool isMin = true; 
void judge(){
	int inc,dec = 0;
	for(int i=0;i<v.size()-1;i++){
		if(isMin&&v[i+1]<v[i]) isMin=false;
		if(isMax&&v[i+1]>v[i]) isMax=false;
	}
}
void output(){
	for(int i=0;i<v.size();i++){
		if(i==0) cout<<v[i];
		else cout<<" "<<v[i];
	}
	cout<<endl;
}
void dfs(int root){
	v.push_back(levelOrder[root]);
	if(2*root>N){
		output();
		judge(); 
		return;
	}
	if(2*root+1<=N){
		dfs(2*root+1);
		v.pop_back();
	} 
	if(2*root<=N){
		dfs(2*root);
		v.pop_back();
	}
}
int main(void){
	cin>>N;
	for(int i=1;i<=N;i++) cin>>levelOrder[i];
	dfs(1);
	if(isMin) puts("Min Heap");
	else if(isMax) puts("Max Heap");
	else puts("Not Heap"); 
	return 0;
}

DFS的另一种写法 

void dfs(int root){
	v.push_back(levelOrder[root]);
	if(2*root>N){
		output();
		v.pop_back(); 
		return;
	}
	if(2*root+1<=N) dfs(2*root+1); 
	if(2*root<=N) dfs(2*root); 
	v.pop_back();
}

AC代码2(利用定义) 

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1007;
int N;
int levelOrder[MAX];
vector<int> v;
bool isMaxHeap(){
	for(int i=1;i<=N/2;i++){
		if(2*i<=N&&levelOrder[i]<levelOrder[2*i]) return false;
		if(2*i+1<=N&&levelOrder[i]<levelOrder[2*i+1]) return false;
	}
	return true;
}
bool isMinHeap(){
	for(int i=1;i<=N/2;i++){
		if(2*i<=N&&levelOrder[i]>levelOrder[2*i]) return false;
		if(2*i+1<=N&&levelOrder[i]>levelOrder[2*i+1]) return false;
	}
	return true;
}
void output(){
	for(int i=0;i<v.size();i++){
		if(i==0) cout<<v[i];
		else cout<<" "<<v[i];
	}
	cout<<endl;
}
void dfs(int root){
	v.push_back(levelOrder[root]);
	if(2*root>N){
		output();
		return;
	}
	if(2*root+1<=N){
		dfs(2*root+1);
		v.pop_back();
	} 
	if(2*root<=N){
		dfs(2*root);
		v.pop_back();
	}
}
int main(void){
	cin>>N;
	for(int i=1;i<=N;i++) cin>>levelOrder[i];
	dfs(1);
	if(isMaxHeap()) puts("Max Heap");
	else if(isMinHeap()) puts("Min Heap");
	else puts("Not Heap");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值