1155 Heap Paths (30point(s))
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.
Sample Input:
8
98 72 86 60 65 12 23 50
Sample Output:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input:
8
8 38 25 58 52 82 70 60
Sample Output:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input:
8
10 28 15 12 34 9 8 56
Sample Output:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题目大意:
输入 N 个节点的完全二叉树,
输出从根节点到所有叶子点的路径,输出顺序由右到左,并判断该树是大顶堆或小顶堆或不是堆
设计思路:
- 按照由右到左 dfs 遍历完全二叉树,队列存储路径,遇到叶子节点输出路径
- 判断大小顶堆,父节点一直比子节点大为大顶堆,父节点一直比子节点小为小顶堆,否则不是堆
编译器:C (gcc)
#include <stdio.h>
int n, tree[1010];
int path[1010] = {0}, cnt = 0;
void dfs(int root)
{
if (root > n)
return ;
path[cnt++] = tree[root];
if (root * 2 > n) {
int i;
printf("%d", path[0]);
for (i = 1; i < cnt; i++)
printf(" %d", path[i]);
printf("\n");
cnt--;
return ;
}
dfs(root * 2 + 1);
dfs(root * 2);
cnt--;
}
void is_heap()
{
int min = 1, max = 1;
int i;
for (i = 2; i <= n; i++) {
if (tree[i / 2] > tree[i])
min = 0;
else if (tree[i / 2] < tree[i])
max = 0;
}
if (min == 1)
printf("Min Heap");
else if (max == 1)
printf("Max Heap");
else
printf("Not Heap");
return ;
}
int main(void)
{
int i;
scanf("%d", &n);
for (i = 1; i <= n; i++)
scanf("%d", &tree[i]);
dfs(1);
is_heap();
return 0;
}