1150 Travelling Salesman Problem (25 point(s))

1150 Travelling Salesman Problem (25 point(s))

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

结合图论的模拟题。由于需要快速根据边的结点获得距离,因此采用邻接矩阵来存储。

思路:

对于每一个给定的序列,首先计算总距离,按照序列顺序计算每两个相邻的结点的距离,每到一个结点标记该结点,如果边不存在,直接跳出循环。 迭代完成后,如果存在没有标记的结点,说明Not a TS cycle,否则,如果是TS simple cycle,则有序列的长度刚好比结点数多1,如果超过1则说明只是TS cycle。

注意对TS simple cycle和TS cycle记录最短距离和路径编号。

#include<iostream>
#include<vector>
#include<cstring>
#include<set>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int MAX = 207;
int N,M,K;
bool visit[MAX]={false};
int graph[MAX][MAX];
int main(void){
	cin>>N>>M;int a,b,dist;
	memset(graph,-1,sizeof(graph));
	for(int i=0;i<M;i++){
		cin>>a>>b>>dist;
		graph[a][b]=dist;
		graph[b][a]=dist;
	}
	cin>>K;
	int l,m;vector<int> v;
	int min = INF;int index =-1;
	for(int j=1;j<=K;j++){
		cin>>l;
		v.clear();
		for(int i=0;i<l;i++){
			cin>>m;
			v.push_back(m);
		}
		memset(visit,false,sizeof(visit));
		bool edgeExist = true;int total = 0;
		for(int i=0;i+1<v.size();i++){
			if(graph[v[i]][v[i+1]]==-1) edgeExist = false;
			else{
				total+=graph[v[i]][v[i+1]];
				visit[v[i+1]]=true; 
			}
		}
		cout<<"Path "<<j<<": ";
		if(!edgeExist){
			cout<<"NA "<<"(Not a TS cycle)"<<endl;
			continue;
		}
		bool isTSC = true;
		for(int i=1;i<=N;i++){
			if(!visit[i]){
				isTSC = false;
				break;
			}
		}
		if(!isTSC){
			cout<<total<<" (Not a TS cycle)"<<endl;
		}
		else{
			cout<<total;
			if(v.size()==N+1) cout<<" (TS simple cycle)"<<endl;
			else if(v.size()>N+1) cout<<" (TS cycle)"<<endl;
			if(total<min){
				index=j;
				min = total;
			}
		}
	}
	cout<<"Shortest Dist("<<index<<") = "<<min<<endl; 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值