Cube HDU - 1220(数学)



Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
Output
For each test case, you should output the number of pairs that was described above in one line.
Sample Input
1
2
3
Sample Output
0
16
297


        
  
The results will not exceed int type.
Hint
Hint
        
 思路:在所有的立方体中任选2个是所有的情况,减去四个公共公共点的情况
总的种类数是C(n*n*n,2) = n*n*n*(n*n*n-1)/2
四个公共点即有一个公共面,那把立方体的所有面数减去外表面的面数,6*n*n*n-6*n*n就是有公共面的立方体数,然后除以2就是有四个公共点的对数(6*n*n*n-6*n*n)/2
然后两个式子相减就是答案
code:
#include <iostream>
using namespace std;
int main(){
    int n,m;
	while(~scanf("%d",&n)){
		m = n*n*n*(n*n*n-1)/2 - (6*n*n*n-6*n*n)/2;
		printf("%d\n",m);
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值