1096. Consecutive Factors (20)(暴力枚举)

31 篇文章 0 订阅
16 篇文章 0 订阅

1096. Consecutive Factors (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

题意:给定一个数字n,那么可以找到几个数字相乘a1*a2*....*ak = n等于这个数,要我们求a1~ak中连续递增子列的最长长度,并输出这个子列,如果有多个长度相同,输出最先出现的那个。

思路:这个题直接遍历枚举即可,但是会出现一个误区,我们遍历寻找的不是n的所以因数,而是枚举几个连续递增的数是n的因数就可以。也就是比如枚举到i,如果i可以整除n,我们把n除以i得到n',然后再判断i+1是否可以整除n',结束后判断最长长度即可。

同时根据这个方法为们发现只需要从2遍历到sqrt(n)即可,因为题目要求1不算入,而当i= sqrt(n),i×(i+1)肯定大于n了


code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int main(){
    int n;
    scanf("%d",&n);
    int m = sqrt(n);
    int first = n;//第一个符合最长序列的开头为n
    int maxlen = 0;//初始化最长长度为0
    for(int i = 2; i <= m; i++){//从2~sqrt(n)枚举)
        int temp = n;
        int start = i;
        while(temp % start == 0){//如果整除
            temp /= start;//除以满足的因数
            start++;//自增,序列长度增加
        }
        if(start - i > maxlen){//超越原有的最长长度,更新
            maxlen = start - i;
            first = i;
        }
    }
    if(maxlen == 0){
        printf("1\n");
        printf("%d\n",n);
    }
    else{
        printf("%d\n",maxlen);
        printf("%d",first);
        for(int i = 1; i < maxlen; i++){
            printf("*%d",first+i);
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值