uva 10080 Gopher II【匈牙利算法】

38 篇文章 0 订阅
12 篇文章 0 订阅

The gopher family, having averted the canine threat, must face a new predator.
The are n gophers and m gopher holes, each at distinct (x,y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input
The input contains several cases. The first line
of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output
Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input
2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output
1


#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const int Maxn=110;
int n,m,s,v;
int match[Maxn];
bool used[Maxn];
vector<int> graphy[Maxn];//存邻接表
struct node
{
    double x,y;
}G[Maxn],H[Maxn];//分别存储松鼠和松鼠洞的坐标,
void initial()
{
    for(int i=0;i<n;i++)
        graphy[i].clear();
}
double distance(double x1,double y1, double x2, double y2)//计算两点之间的距离
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
/*bool dfs(int v)
{
    //used[v]=true;
    for(int i=0;i<graphy[v].size();i++)
    {
        int u=graphy[v][i];
        int w=match[u];
        if(!used[u])
        {
            used[u]=true;
            if(w<0||dfs(w))
            {
                match[u]=v;
                //match[v]=u;
                return true;
            }
        }
    }
    return false;
}*/
bool dfs(int u)
{
    for (int i=0; i<graphy[u].size ();i++)//循环与第u只松鼠洞有连线的松鼠
         {
            int v = graphy[u][i];
            if (!used[v])//若松鼠v未被访问
                {
                    used[v] = true;
                    if (match[v] == -1 || dfs (match[v]))//松鼠v未匹配或与松鼠v匹配的松鼠洞有其他匹配
                    {
                        match[v] = u;//将松鼠洞u与松鼠v匹配
                        return true;
                    }
                }
         }
    return false;
}
int bipartite_matching()//二部图匹配
{
    int res=0;
    memset(match,-1,sizeof(match));//将所有松鼠的匹配都置为 -1
    for(int i=0;i<n;i++)
    {
        memset(used,false,sizeof(used));//每次dfs某松鼠洞的匹配前将所有松鼠都设为未访问
        if(dfs(i))
            res++;
    }
    return res;
}
int main()
{
    int ans;
    while(cin>>n>>m>>s>>v)
    {
        for(int i=0;i<n;i++)
        {
            cin>>G[i].x>>G[i].y;//读取松鼠坐标
        }
        for(int i=0;i<m;i++)
        {
            cin>>H[i].x>>H[i].y;//读取松鼠洞的坐标
        }
        initial();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(distance(G[i].x,G[i].y,H[j].x,H[j].y)<=v*s)
                {
                    graphy[i].push_back(j);
                }
            }
        }
       ans=bipartite_matching();
        cout<<n-ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值