百练 3420: Exchange Rates

百练 3420: Exchange Rates

原题OJ链接

描述

Now that the Loonie is hovering about par with the Greenback, you have decided to use your $1000 entrance scholarship to engage in currency speculation. So you gaze into a crystal ball which predicts the closing exchange rate between Canadian and U.S. dollars for each of the next several days. On any given day, you can switch all of your money from Canadian to U.S. dollars, or vice versa, at the prevailing exchange rate, less a 3% commission, less any fraction of a cent.
Assuming your crystal ball is correct, what’s the maximum amount of money you can have, in Canadian dollars, when you’re done?

输入

The input contains a number of test cases, followed by a line containing 0. Each test case begins with 0<d<=365, the number of days that your crystal ball can predict. d lines follow, giving the price of a U.S. dollar in Canadian dollars, as a real number.

输出

For each test case, output a line giving the maximum amount of money, in Canadian dollars and cents, that it is possible to have at the end of the last prediction, assuming you may exchange money on any subset of the predicted days, in order.

样例输入

3
1.0500
0.9300
0.9900
2
1.0500
1.1000
0

样例输出

1001.60
1000.00

解题思路

这道题的难点在于英文阅读hhh。有几个坑:1)题目中的$1000指的是 Loonie,即 Canadian dollars 。2)less any fraction of a cent,这个是说小于美分的部分都舍去,所以代码中将初始的 1000 定义为100000,然后用int 取整。注意格式化输出,保留小数点后两位,用printf("%.2f\n",CA/100.0)
代码中的CA表示加拿大元,US表示美元。题目的意思是要输出最终经过汇率转化后的CA的最大值,每次转化都要付出3%的额外费用。

源代码

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
    int d;

    while(cin>>d && d!=0){
        int CA=100000, US=0;
        double rate;
        for(int i=0;i<d;i++){
            cin>>rate;
            CA=max(CA,(int)(US*rate*0.97));
            US=max(US,(int)(CA/rate*0.97));
        }
        printf("%.2f\n",CA/100.0);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值