hdu 1903 Exchange Rates(动态规划)

Exchange Rates

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 392    Accepted Submission(s): 165


Problem Description
Now that the Loonie is hovering about par with the Greenback, you have decided to use your $1000 entrance scholarship to engage in currency speculation. So you gaze into a crystal ball which predicts the closing exchange rate between Canadian and U.S. dollars for each of the next several days. On any given day, you can switch all of your money from Canadian to U.S. dollars, or vice versa, at the prevailing exchange rate, less a 3% commission, less any fraction of a cent. 
Assuming your crystal ball is correct, what's the maximum amount of money you can have, in Canadian dollars, when you're done? 
 

Input
The input contains a number of test cases, followed by a line containing 0. Each test case begins with 0 <d &#8804; 365, the number of days that your crystal ball can predict. d lines follow, giving the price of a U.S. dollar in Canadian dollars, as a real number. 
 

Output
For each test case, output a line giving the maximum amount of money, in Canadian dollars and cents, that it is possible to have at the end of the last prediction, assuming you may exchange money on any subset of the predicted days, in order. 
 

Sample Input
  
  
3 1.0500 0.9300 0.9900 2 1.0500 1.1000 0
 

Sample Output
  
  
1001.60 1000.00
//0代表美元,1代表加元  double dp[444][3];dp[i][j]代表类型为i的货币持有j天能达到的最大收益。另外本题要额外注意精度,具体来说是*100截取整数然后
除以100两位浮点数输出
#include<iostream>
#include<cstring>

using namespace std;

int n;
double rate[444];

//0代表美元,1代表加元 
double dp[444][3];
int main()
{
	while(cin>>n,n)
	{
		for(int i=1;i<=n;i++)cin>>rate[i];
		
		//第一天如果换成美元的话 
		 dp[1][0]=1000/rate[1]*100*0.97;
		 //第一天如果还持有加元的话 
		 dp[1][1]=1000*100;
		 
		 for(int i=2;i<=n;i++)
		 {
		 	dp[i][0]=(int)max(dp[i-1][0],dp[i-1][1]/rate[i]*0.97)+0.0;
		 	dp[i][1]=(int)max(dp[i-1][1],dp[i-1][0]*rate[i]*0.97)+0.0;
		  } 
		  
		  printf("%.2lf\n",dp[n][1]/100.0);
	}
	
	
	return 0;
 } 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值