Fibonacci Again

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

一个斐波那契数列数列,且F[0]=7,F[1]=11,题目问F[n]能否被3整除,能整除输出yes,否则输出no。有公式(a+b)%p=(a%p+b%p)%p,根据这个公式,就可以算出整个数列上每一项MOD3,如果这一项为0,输出yes,否则输出no。

C

#include <stdio.h>
#pragma warning(disable:4996)
int f[1000000]={1,2};
int main(void)
{
	int i=2,n;
	while(scanf("%d",&n)!=EOF)
	{
		for(;i<=n;i++)           //i=2的初始化放在声明那里,可以节省一点时间,数组只会遍历一遍
			f[i]=(f[i-1]%3+f[i-2]%3)%3;
		if(f[n]==0)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值