Best Cow Fences POJ - 2018(经典二分)

Farmer John’s farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.

Calculate the fence placement that maximizes the average, given the constraint.
Input
* Line 1: Two space-separated integers, N and F.

  • Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.
    Output
  • Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields.
    Sample Input
    10 6
    6
    4
    2
    10
    3
    8
    5
    9
    4
    1
    Sample Output
    6500
    评价:题意是在一个数组里,寻找一段连续和,使其平均和最大,但是长度不能小于F,
    首先可以看出是满足单调性的,但是怎么二分呢,
    我们先枚举一个可能的数。
    然后数组里的值全部减去这个值(结果会有正有负),那么我们就看是否存一段长度大于等于F,且和为正。对于此的判断,可谓经典,见代码。
    AC
#include<iostream>
#include<cstdio>
#include<vector>
#define maxx 400005
using namespace std;
double a[100005];
double b[100005];
double c[100005];
int main()
{

        int n;
        int f;
        cin>>n>>f;
        for(int i=1;i<=n;i++)
            scanf("%lf",a+i);
        double eps=1e-5;
        double l=-1e6,r=1e6;
        while(r-l>eps)
        {
            double mid=(l+r)/2;
            for(int i=1;i<=n;i++)b[i]=a[i]-mid;
            for(int i=1;i<=n;i++)
                c[i]=c[i-1]+b[i];//求前缀和,
            double ans=-1e10;
            double minn=1e10;
            for(int i=f;i<=n;i++)
            {
                minn=min(minn, c[i-f]);不断维护左端的最小值
                ans=max(ans, c[i]-minn);//相见得到区间和,不断忘正值靠近
            }//核心
            if(ans>=0)
                l=mid;
            else
                r=mid;
        }
        cout<<(int)(r*1000);
    return 0;
}
Fences是一个用于整理和排布电脑桌面图标的软件。首先,你需要下载和安装Fences免费软件,并确保你的系统符合要求(Windows XP/Vista/7)。 一旦安装完成,你可以按照以下步骤使用Fences: 1. 打开Fences软件。在桌面上,你将看到一个默认的"Fence",它是一个用于组织图标的容器。 2. 可以通过拖动桌面上的图标来将其放入Fence中。你可以创建多个Fence来组织不同类别的图标。 3. 如果你想创建一个新的Fence,只需在桌面上点击右键,选择"Fences",然后点击"Create New Fence"。这将在桌面上创建一个新的Fence。 4. 你还可以自定义Fence的属性。右键点击Fence,选择"Configure Fence"。在这里,你可以更改Fence的名称、颜色和透明度等。 5. 如果你不再需要某个Fence,可以将其删除。右键点击Fence,选择"Delete Fence"。这将删除该Fence以及其中的图标。 总的来说,Fences可以帮助你快速整理桌面图标,并将其分组显示,使得你的桌面更加整洁和有序。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [【经验分享】F e n c e s 桌面布局软件(Win All)----中文免费版+教程](https://blog.csdn.net/qq_51237779/article/details/127546142)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [Fences -让你的桌面图标分组显示,成块状化](https://blog.csdn.net/alex197963/article/details/4806096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值