烘衣服(二分)

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
sample output #1
3

sample output #2
2

题意:有n个洗完的衣服,每个含有a[i]的水,自然晾干每分钟凉1水量,只有一个干燥器,一次只能干燥一件衣服,每分钟可干燥k水量,问最小化的干燥时间(所有衣服);
解题思路:
二分所需要干燥的时间mid,如果我们用这么多时间晾干衣服,那么衣服中水的含水量低等于mid的可以自动晾干,只需要处理大于mid的衣服,对这些衣服,如果花时间t用来干燥,那么就有(mid-t)的时间自动晾干,所以对当前的a[i]>=t*k+(mid-t),所以尽可能小的时间就是t=(a[i]-mid)/(k-1)遍历每个a[i],记录时间t,如果t大于当前mid,说明该mid时间不够,反之mid偏大;

#include <math.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
long long a[100005];
long long n,k;
long long judge(long long t)
{           
    long long i,sum;                    
    sum=0;                     
    for(i=0;i<n;i++) //k*x+(t-x)>=a[i],推出x>=(a[i]-t)/(k-1)
    if(a[i]>t)
    sum+=(long long)(ceil((a[i]-t)*1.0/(k-1)));//ceil向上取整 
    return sum;
}
int main(){
    long long i,l,r,ans,mid;
    while(~scanf("%lld",&n))
	{
        l=r=ans=0;
        for(i=0;i<n;i++)
	        scanf("%lld",&a[i]);
        scanf("%lld",&k);
        sort(a,a+n);
        r=a[n-1];
        if(k==1)
		{                    
            printf("%lld\n",r);       
            continue;
        }
        while(l<=r)
		{                    
            mid=(l+r)/2;
            if(judge(mid)<=mid)//说明在mid时间内烘干机有空闲时间还能继续使用,时间还能更短
			{
                ans=mid;
                r=mid-1;
            }
            else//说明mid时间内烘不干,需要更长的时间
            l=mid+1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值