Hdu 1907 John

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
  
  
2 3 3 5 1 1 1
 

Sample Output
  
  
John Brother
 

分为两种情况:

1 每个盒子里都只有一颗巧克力;

2 至少有一个盒子的巧克力数量大于一。

对于1情况,若是奇数个盒子,那么John输,否则John赢。

对于2情况,则是尼姆博弈。



#include<cstdio>

int main()
{
    int T,N,x,tmp,flag;

    scanf("%d",&T);

    while(T--)
    {
        tmp=0;
        flag=0;
        scanf("%d",&N);
        while(N--)
        {
            scanf("%d",&x);
            tmp^=x;
            if(x>1)
                flag=1;
        }
        if(flag==1)
        {
            if(tmp==0)
                printf("Brother\n");
            else
                printf("John\n");
        }
        else
        {
            if(tmp!=0)
                printf("Brother\n");
            else
                printf("John\n");
        }
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值