HDU 4927 Series 1 杨辉三角形

Series 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 921    Accepted Submission(s): 342


Problem Description
Let A be an integral series {A 1, A 2, . . . , A n}.

The zero-order series of A is A itself.

The first-order series of A is {B 1, B 2, . . . , B n-1},where B i = A i+1 - A i.

The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).

Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 

Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).

For each test case:
The first line contains a single integer n(1<=n<=3000), which denotes the length of series A.
The second line consists of n integers, describing A 1, A 2, . . . , A n. (0<=A i<=10 5)
 

Output
For each test case, output the required integer in a line.
 

Sample Input
   
   
2 3 1 2 3 4 1 5 7 2
 

Sample Output
   
   
0 -5
 

Author
BUPT
 
系数是杨辉三角并且是高精度,用java处理。
//515MS	9976K
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		int t;
		t=cin.nextInt();
		for(int cas=1;cas<=t;cas++){
			BigInteger ans=BigInteger.valueOf(0);
			int n;
			n=cin.nextInt();
			BigInteger yanghui[]=new BigInteger[n];
			BigInteger s[]=new BigInteger[n+2];
			for(int i=0;i<n;i++)
				s[i]=cin.nextBigInteger();
			if (n == 1) {  
                System.out.println(s[0]);  
                continue;  
            }  
			yanghui[0]=BigInteger.valueOf(1);
			for(int i=1;i<n;i++){
				BigInteger x1=BigInteger.valueOf(i);
				BigInteger x2=BigInteger.valueOf(n-i);
				yanghui[i]=yanghui[i-1].multiply(x2).divide(x1);
			}
			boolean flag=true;
			for(int i=n-1;i>=0;i--){
				if(flag){ans=ans.add(yanghui[i].multiply(s[i]));flag=false;}
				else {ans=ans.subtract(yanghui[i].multiply(s[i]));flag=true;}
			}
			System.out.println(ans);		
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值