Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4260 Accepted Submission(s): 2766
原题链接: 点击打开链接
Total Submission(s): 4260 Accepted Submission(s): 2766
原题链接: 点击打开链接
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
Source
Recommend
Eddy
#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#define LL long long
#define MAXI 2147483647
#define MAXL 9223372036854775807
#define eps (1e-8)
#define dg(i) cout << "*" << i << endl;
using namespace std;
int w, h, sx, sy, cnt;
char map[22][22];
char d[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
void DFS(int i, int j)
{
int ii, jj, k;
for(k = 0; k < 4; k++)
{
ii = i + d[k][0];
jj = j + d[k][1];
if(ii > -1 && jj > -1 && ii < h && jj < w && map[ii][jj] == '.')
{
cnt++;
map[ii][jj] = '#';
DFS(ii, jj);
}
}
}
int main()
{
int i, j;
while(scanf("%d %d", &w, &h) && w)
{
cnt = 1;
for(i = 0; i < h; i++)
{
scanf("%s", map[i]);
}
for(i = 0; i < h; i++)
{
for(j = 0; j < w; j++)
if(map[i][j] == '@')
{
sx = j;
sy = i;
i = h;
break;
}
}
DFS(sy, sx);
printf("%d\n", cnt);
}
return 0;
}