Red and Black 【DFS】【连通区域的大小】

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19500    Accepted Submission(s): 11866


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source

思路 其实就是求连通着的 黑其 有几个
代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
#include<vector>
#define inf 0x3f3f3f
#define M 25
#define mod 100
using namespace std;
typedef struct 
{
	int x,y,num;
}dot;
int n,m;
int maxnum;
int map[M][M];
int to[4][2]={0,1,0,-1,1,0,-1,0};
void dfs(int x,int y)
{
	map[x][y]=0; 
	for(int i=0;i<4;i++)
	{
		int x1=x+to[i][0];
		int y1=y+to[i][1];
		if(map[x1][y1])
		{
			maxnum++;
			dfs(x1,y1);	 //一开始写成 dfs(x1,y1,sum+1) 这个是求一条路上过程中的最大的个数, 
		}				//但是本题的意思是求整个过程的个数 
	}
}
int main()
{
	while(scanf("%d%d",&m,&n)&&(n||m))
	{
		dot st;
		memset(map,0,sizeof(map));
		for(int i=1;i<=n;i++)
		{
			getchar();
			for(int j=1;j<=m;j++)
			{
				char s;
				scanf("%c",&s);
				if(s=='.') map[i][j]=1;
				if(s=='@')
				{
				st.x=i;
				st.y=j;	
				 }
			}
		}
		maxnum=1;
		dfs(st.x,st.y);
		printf("%d\n",maxnum);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值