Red and Black(DFS)

Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output
45
59
6
13

题意:在一个n*m的数组中,找从字符@的位置出发,每次只能走上下左右四个方向,一共可以经过多少’.’,输出从其实位置出发,能到达的.的总个数。

题解:DFS,可作为模板题。

DFS

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

char a[21][21];
int dx[5]= {-1,1,0,0},dy[5]= {0,0,-1,1}; //偏移量;
int m,n,ans;
void dfs(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m&&a[x][y]!='#') //遇到符合要求的就给标记为#,防止下次重复经过
    {                                      //同时ans++;
        a[x][y]='#';
        ans++;
    }
    else
        return ;
    for(int i=0; i<4; i++)    //尝试四个方向(上、下、左、右);
        dfs(x+dx[i],y+dy[i]);
}
int main()
{
    while(cin>>m>>n)
    {
        if(!m&&!n)
            break;
        int x,y;
        ans=0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                    x=i,y=j;
            }
        }
        dfs(x,y);
        cout<<ans<<endl;
    }
    return 0;
}

BFS:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

char a[21][21];
int dx[5]={-1,1,0,0},dy[5]={0,0,-1,1}; //偏移量;
struct node
{
    int x,y;
}p1,p2;   //用结构体来保存每个队列中元素的值,p1是每次新加入的结点,p2代表结点;
int n,m,ans;
void bfs(int x,int y)
{
    queue<node>q;
    p1.x=x,p1.y=y;    
    a[p1.x][p1.y]='#';
    ans++;     
    q.push(p1);   //把第一个符合要求的元素先压入队列,注意ans++;
    while(!q.empty())  //队列要非空,说明还可以继续往下搜索;
    {
       p2=q.front();  //队首元素取出作为父结点;
       q.pop();      //用完即弹出;
       for(int i=0;i<4;i++)  //尝试每个方向;
       {
           p1.x=p2.x+dx[i];
           p1.y=p2.y+dy[i];
           if(p1.x>=0&&p1.x<n&&p1.y>=0&&p1.y<m&&a[p1.x][p1.y]!='#')
           {
               a[p1.x][p1.y]='#';
               q.push(p1);  //把符合要求的点加入队列,同时ans++;
               ans++;
           }
       }
    }
}
int main()
{
    while(cin>>m>>n)
    {
        if(!m&&!n)
            break;
        int x,y;
        ans=0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                    x=i,y=j;
            }
        }
        bfs(x,y);
        cout<<ans<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值