并查集 集合内的分类问题

并查集 集合内的分类问题

普通的并查集对于集合内的元素无法分类,我们用一个数组表示其类型就行了。主要并查集在压缩路径的过程是动态维护的,表示类型类型也要随之而变。

注意

  • 这儿的类型关系应该是环形的(像POJ食物链 的关系一样,是相对有等级的)
  • 调用val[x]时应先调用find(x),find()不止是查找,还有跟新x->根的所有关系的作用

话不多说,直接上代码。不懂的可以看看这篇文章》》传送门

#define MAX_N 【原始最多个数】
#define CLASS 【类型数】
int par[MAX_N];
int val[MAX_N];

void init(int n){for(int i=0;i<=n;i++) par[i]=i,val[i]=0;}

int find(int x){
    if(x==par[x]) return x;

    int t=find(par[x]);
    val[x]=val[par[x]]+val[x];
    val[x]%=CLASS;
    return par[x]=t;
}

void unite(int x,int y,int R){
    int fx=find(x),fy=find(y);
    par[fy]=fx;
    val[fy] =CLASS+val[x]-val[y]+R;
    val[fy]%=CLASS;
}

bool same(int x,int y){return find(x)==find(y);}

再附上一个题

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:

No suspicious bugs found!

Hint

Huge input,scanf is recommended.

代码

#include<stdio.h>
#define MAX_N 2002
#define CLASS 2
int par[MAX_N];
int val[MAX_N];

void init(int n){for(int i=0;i<=n;i++) par[i]=i,val[i]=0;}

int find(int x){
    if(x==par[x]) return x;

    int t=find(par[x]);
    val[x]=val[par[x]]+val[x];
    val[x]%=CLASS;
    return par[x]=t;
}

void unite(int x,int y,int R){
    int fx=find(x),fy=find(y);
    par[fy]=fx;
    val[fy] =CLASS+val[x]-val[y]+R;
    val[fy]%=CLASS;
}

bool same(int x,int y){return find(x)==find(y);}

int main()
{
    int T,n,m;
    scanf("%d",&T);
    for(int t=1;t<=T;t++){
        scanf("%d%d",&n,&m);
        init(n);

        bool flag=false;
        for(int i=0,x,y;i<m;i++){
            scanf("%d%d",&x,&y);
            if(!same(x,y)) unite(x,y,1);
            else if(val[x]==val[y]) flag=true;
        }
        printf("Scenario #%d:\n%suspicious bugs found!\n\n",t,flag?"S":"No s");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值