The Game

18 篇文章 0 订阅
13 篇文章 0 订阅

One morning, you wake up and think: "I am such a good programmer. Why not make some money?'' So you decide to write a computer game. 
The game takes place on a rectangular board consisting of w * h squares. Each square might or might not contain a game piece, as shown in the picture. 

One important aspect of the game is whether two game pieces can be connected by a path which satisfies the two following properties: 

It consists of straight segments, each one being either horizontal or vertical. 


It does not cross any other game pieces. 

(It is allowed that the path leaves the board temporarily.) 

Here is an example: 

The game pieces at (1,3) and at (4, 4) can be connected. The game pieces at (2, 3) and (3, 4) cannot be connected; each path would cross at least one other game piece.

The part of the game you have to write now is the one testing whether two game pieces can be connected according to the rules above.
Input
The input contains descriptions of several different game situations. The first line of each description contains two integers w and h (1 <= w,h <= 75), the width and the height of the board. The next h lines describe the contents of the board; each of these lines contains exactly w characters: a "X" if there is a game piece at this location, and a space if there is no game piece. 

Each description is followed by several lines containing four integers x1, y1, x2, y2 each satisfying 1 <= x1,x2 <= w, 1 <= y1,y2 <= h. These are the coordinates of two game pieces. (The upper left corner has the coordinates (1, 1).) These two game pieces will always be different. The list of pairs of game pieces for a board will be terminated by a line containing "0 0 0 0". 

The entire input is terminated by a test case starting with w=h=0. This test case should not be procesed.
Output
For each board, output the line "Board #n:", where n is the number of the board. Then, output one line for each pair of game pieces associated with the board description. Each of these lines has to start with "Pair m: ", where m is the number of the pair (starting the count with 1 for each board). Follow this by "ksegments.", where k is the minimum number of segments for a path connecting the two game pieces, or "impossible.", if it is not possible to connect the two game pieces as described above. 

Output a blank line after each board.
Sample Input
5 4
XXXXX
X   X
XXX X
 XXX 
2 3 5 3
1 3 4 4
2 3 3 4
0 0 0 0
0 0
Sample Output
Board #1:
Pair 1: 4 segments.
Pair 2: 3 segments.
Pair 3: impossible.

解题报告


直接广搜就行了,由队列的每个点向四个方向标记直到遇到'X',小心每组结束还有个\n,


#include<stdio.h>
#include<string.h>
#include<queue>
#define MAX_N 80
#define INF 0x3f3f3f3f
using namespace std;
char map[MAX_N][MAX_N];
int dp[MAX_N][MAX_N];
const int ox[]={0,0,1,-1};
const int oy[]={1,-1,0,0};
int w,h;
int s_x,s_y,e_x,e_y;

int bfs(){
    memset(dp,0x3f,sizeof(dp));
    queue<pair<int,int> > que;
    que.push(make_pair(s_x,s_y));
    dp[s_y][s_x]=0;
    map[e_y][e_x]=' ';
    int H=h+1,W=w+1;
    
    while(!que.empty()){
        int X=que.front().first,Y=que.front().second;que.pop();
        int S=dp[Y][X]+1;
        for(int i=0;i<4;i++){
            int x=X,y=Y;
            while(true){
                x+=ox[i],y+=oy[i];
                if(x<0||x>W||y<0||y>H||map[y][x]=='X') break;
                if(dp[y][x]<=S) continue;
                que.push(make_pair(x,y));
                dp[y][x]=S;
            }
        }
    }
    map[e_y][e_x]='X';
    return dp[e_y][e_x];
}

int main()
{
    int Board=1,Pair;
    while(~scanf("%d%d",&w,&h)&&w&&h){
        memset(map,0,sizeof(map));
        getchar();
        for(int i=1;i<=h;i++)
            gets(map[i]+1);
        printf("Board #%d:\n",Board++);Pair=1;
        while(scanf("%d%d%d%d",&s_x,&s_y,&e_x,&e_y)&&s_x&&s_y&&e_x&&e_y){
            printf("Pair %d: ",Pair++);
            int ans=bfs();
            if(ans==INF) puts("impossible.");
            else printf("%d segments.\n",ans);
        }
        putchar('\n');
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值