PAT 1144 The Missing Number

原题链接:1144 The Missing Number (20分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:
Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题目大意:

给定一串数,要求返回不在给定数中的最小正数

方法一:set

思路:

遍历这串数,将其中的正数添加到set中,set会自己去重和排序
最后将ans从小到大递增,当ans不在set中时,将set输出即可

C++ 代码:

#include <iostream>
#include <set>
using namespace std;

int n, t;
set<int> s;

int main(){
    scanf("%d", &n);
    while(n--){
        scanf("%d", &t);
        if(t > 0)
            s.insert(t);
    }

	int ans = 1;
    while(s.find(ans) != s.end())
        ans++;

	printf("%d", ans);
    
    return 0;
}

复杂度分析:

  • 时间复杂度:O(n),一遍插入,一次循环
  • 空间复杂度:O(n),set最大长度为n
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值