PAT 1066 Root of AVL Tree

原题链接:PAT 1066 Root of AVL Tree (25分)
关键词:AVL树模板题

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在这里插入图片描述

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

题目大意: 给出一些整数序列让你按顺序插入得到平衡二叉树,最终输出AVL的根
思路: AVL的模板题,理解思想很重要
代码:

#include <iostream>
using namespace std;

struct node {
    int value;
    struct node *l, *r;
};

node* L(node *root) {
    node *t = root->r;
    root->r = t->l;
    t->l = root;
    return t;
}
node* R(node *root) {
    node *t = root->l;
    root->l = t->r;
    t->r = root;
    return t;
}
node* LR(node *root) {
    root->l = L(root->l);
    return R(root);
}
node* RL(node *root) {
    root->r = R(root->r);
    return L(root);
}

int getHeight(node *root) {	//得到以当前结点为根的子树的高度
    if(root == NULL) return 0;
    return max(getHeight(root->l), getHeight(root->r)) + 1;
}
node *insert(node *root, int val) {	//插入建树
    if(root == NULL) {
        root = new node();
        root->value = val;
        root->l = root->r = NULL;
    } 
    else if(val < root->value) {  //插入左子树
        root->l = insert(root->l, val);
        if(getHeight(root->l) - getHeight(root->r) == 2)
            root = val < root->l->value ? R(root) : LR(root);
    } 
    else {  //插入右子树
        root->r = insert(root->r, val);
        if(getHeight(root->l) - getHeight(root->r) == -2)
            root = val > root->r->value ? L(root) : RL(root);
    }
    return root;
}
int main() {
    int n, val;
    scanf("%d", &n);
    node *root = NULL;
    for(int i = 0; i < n; i++) {
        scanf("%d", &val);
        root = insert(root, val);
    }
    printf("%d", root->value);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值