原题链接:1125 Chain the Ropes (25分)
关键词:简单模拟
Given some segments(段) of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.
Your job is to make the longest possible rope out of N given segments.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤104 ). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.
Output Specification:
For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.
Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14
题目大意: 给你很多个绳子段,让你按它给的方法把绳子绑成一条,要求绳子的长度最长。
分析: 说实话读题读了半天…… 每次绑上新的绳子段,需要将原来的绳子长变为一半。以a、b、c来说,最终长度:((a+b)\2+c)\2,可以看到,如果要最终绳子最长,那么需要按递增的顺序将绳子段绑上。
代码:
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 1e4 + 10;
int a[maxn], n;
int main(){
scanf("%d", &n);
for(int i = 0; i < n; i ++ ){
scanf("%d", &a[i]);
}
sort(a, a+n);
int ans = a[0];
for(int i = 1; i < n; i ++ ){
ans += a[i];
ans /= 2;
}
printf("%d", ans);
return 0;
}