PAT 1115 Counting Nodes in a BST

原题链接:1115 Counting Nodes in a BST (30分)
关键词:BST

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  1. The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  2. The right subtree of a node contains only nodes with keys greater than the node’s key.
  3. Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

题目大意: 给出一组数构建BST,让你输出最下面两层的结点数。

分析: 建树,然后用dfs遍历,递归到孩子就将h+1,并用数组记录每个高度的节点数。

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e4 + 10;

struct node{
    int val, h;
    node *l, *r;
};

node* insert(node* root, int value){   //插入建树
    if(root == NULL){
        root = new(node);
        root->val = value;
        root->l = root->r = NULL;
    }
    else{
        if(value <= root->val) root->l = insert(root->l, value);
        else root->r = insert(root->r, value);
    }
    return root;
}

int mx = -1;    //mx-1为最大高度
int num[maxn];  //记录每个高度的节点数
void dfs(node* root, int h){
    if(root == NULL){
       mx = max(mx, h);
       return;
    }
    num[h]++;
    dfs(root->l, h + 1);
    dfs(root->r, h + 1);
}

int main(){
    int n;
    scanf("%d", &n);
    node* root = NULL;
    for(int i = 0; i < n; i ++ ){
        int x;
        scanf("%d", &x);
        root = insert(root, x);
    }
    dfs(root, 1);
    //printf("%d\n", mx);
    printf("%d + %d = %d", num[mx-1], num[mx-2], num[mx-1] + num[mx-2]);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值