PAT 1119 Pre- and Post-order Traversals (30分)

原题链接:1119 Pre- and Post-order Traversals (30分)
关键词:树的遍历、前序后序推中序

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

题目大意: 给出你一棵树的前序遍历和后序遍历,问你这棵树的中序遍历是否唯一,并输出中序遍历。

分析:
如果一个结点只有一个孩子,那么这个结点可是是左孩子也可以是右孩子,因此中序遍历就不唯一了;

柳神的做法:已知二叉树的前序和后序是无法唯一确定一颗二叉树的,因为可能会存在多种情况,这种情况就是一个结点可能是根的左孩子也有可能是根的右孩子,如果发现了一个无法确定的状态,置unique = 0,又因为题目只需要输出一个方案,可以假定这个不可确定的孩子的状态是右孩子,接下来的问题是如何求根结点和左右孩子划分的问题了,首先我们需要知道树的表示范围,需要四个变量,分别是前序的开始的地方prel,前序结束的地方prer,后序开始的地方postl,后序结束的地方postr,前序的开始的第一个应该是后序的最后一个是相等的,这个结点就是根结点,以后序的根结点的前面一个结点作为参考,寻找这个结点在前序的位置,就可以根据这个位置来划分左右孩子,递归处理

代码:

// pat 1119
#include <bits/stdc++.h>
using namespace std;

int n;
vector<int> pre, post, in;
bool flag = true;	//中序是否唯一 

void getIn(int prel, int prer, int postl, int postr){
	if(prel == prer){
		in.push_back(pre[prel]);
        return;
	}
	if(pre[prel] == post[postr]){	//这个位置是根结点 
		int i = prel + 1;
		while(i <= prer && pre[i] != post[postr - 1]) i ++;	//i找到后续遍历中根结点的前一个结点 
		if(i - prel > 1)
			getIn(prel + 1, i-1, postl, postl+(i-prel-1)-1); 
		else 
			flag = false;	//不唯一 
		in.push_back(post[postr]); 
        getIn(i, prer, postl + (i-prel-1), postr-1);
    }
}

int main(){
	scanf("%d", &n);
	pre.resize(n);
	post.resize(n);
	
	for(int i = 0; i < n; i ++ ) scanf("%d", &pre[i]);
	for(int i = 0; i < n; i ++ ) scanf("%d", &post[i]);
	
	getIn(0, n-1, 0, n-1); //或得中序序列 
	//输出 

	if(flag) puts("Yes");
	else puts("No"); 
	for(int i = 0; i < in.size(); i ++ ){
		if(i) printf(" ");
		printf("%d", in[i]);
	}
    printf("\n");	//不输出换行符就会格式错误
    	
	return 0;
} 

注意: 要在输出的结尾输出一个换行符,否则会格式错误!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值