PAT 1098 Insertion or Heap Sort (25分)

原题链接:1098 Insertion or Heap Sort (25分)
关键词:插入排序、堆排序
整理时间:2020.7.24

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题目大意: 给出一组数,和这组数经过某种排列的中间状态,问你它是什么插入排序还是堆排序,并输出再排序一次的结果。

分析:

插入排序的特点是:前面的顺序是从小到大的,后面的顺序不一定,但是一定和原序列的后面的顺序相同,其中粗体部分是已经完成排序的部分:
原始: 3 1 2 8 7 5 9 4 6 0
中间: 1 2 3 7 8 5 9 4 6 0
插入排序的下一步就是把第一个不符合从小到大的顺序的那个元素插入到前面已排序的里面的合适的位置,那么只要对前几个已排序的和后面一位这个部分用一次sort即可。
下趟:1 2 3 5 7 8 9 4 6 0


堆排序的特点是后面是从小到大的(已经完成排序的),前面的顺序不一定,又因为是从小到大排列,堆排序完成之前堆为大顶堆,前面未排序的序列的最大值为b[1]。

那么就可以从n开始往前找,找第一个小于等于b[1]的数字b[p](while(p > 2 && b[p] >= b[1]) p--;),把它和堆顶交换(swap(b[1], b[p]);),然后把数组b在1~p-1区间(也就是未完成排序的部分)进行一次向下调整(downAdjust(b, 1, p - 1);

大顶推得到未排序的数中最大的数,然后和未排序的最后一个数进行交换。调整堆。重复这个过程直到堆中只剩下一个元素。
原始:3 1 2 8 7 5 9 4 6 0
中间:6 4 5 1 0 3 2 7 8 9
下趟:5 4 3 1 0 2 6 7 8 9

堆排序:

void heapsort(){
	createheap();	//建堆
	for(int i = n; i > 1; i--){
		swap(heap[1], heap[l]);
		downAdjust(l, i-1);
	}
}

完整代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

void downAdjust(vector<int> &b, int low, int high) {	//调整范围low-high
    int i = 1, j = i * 2;	//i为欲调整结点,j为左孩子
    while(j <= high) {	//存在孩子结点
    	//如果右孩子存在且比左孩子大,让j存储右孩子坐标
        if(j + 1 <= high && b[j] < b[j + 1]) j = j + 1;
        if (b[i] >= b[j]) break;	//孩子结点小,退出
        swap(b[i], b[j]);	//否则交换
        i = j; 
        j = i * 2;
    }
}

int main() {
    int n, p = 2;
    scanf("%d", &n);
    vector<int> a(n + 1), b(n + 1);
    
    for(int i = 1; i <= n; i++) scanf("%d", &a[i]);	//原始序列
    for(int i = 1; i <= n; i++) scanf("%d", &b[i]);	//中间序列
    
    while(p <= n && b[p - 1] <= b[p]) p++;	//第一个不满足右边比左边大的数
    int index = p;
    while(p <= n && a[p] == b[p]) p++;
    if(p == n + 1) {	//后面都满足与原先序列相同
        printf("Insertion Sort\n");
        sort(b.begin() + 1, b.begin() + index + 1);
    } 
    else {
        printf("Heap Sort\n");
        p = n;
        while(p > 2 && b[p] >= b[1]) p--;	//从后往前找到第一个小于堆顶的数
        swap(b[1], b[p]);
        downAdjust(b, 1, p - 1);
    }
	
	//输出结果
    printf("%d", b[1]);
    for(int i = 2; i <= n; i++)
        printf(" %d", b[i]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值