H - A Knight's Journey

本文介绍了一种骑士在不规则棋盘上寻找遍历所有方格路径的问题,要求找到一条从任意方格出发并回到该方格,且每个方格只访问一次的路径。题目提供输入为棋盘的行数和列数,并要求输出按字典序排列的可行路径或在无解时输出"impossible"。
摘要由CSDN通过智能技术生成

Background The knight is getting bored of seeing the same black and
white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one
direction and one square perpendicular to this. The world of a knight
is the chessboard he is living on. Our knight lives on a chessboard
that has a smaller area than a regular 8 * 8 board, but it is still
rectangular. Can you help this adventurous knight to make travel
plans?
Problem Find a path such that the knight visits every square once.
The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The
following lines contain n test cases. Each test case consists of a
single line with two positive integers p and q, such that 1 <= p * q
<= 26. This represents a p * q chessboard, where p describes how many
different square numbers 1, … , p exist, q describes how many
different square letters exist. These are the first q letters of the
Latin alphabet: A, …

Output

The output for every scenario begins with a line containing “Scenario
#i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits
all squares of the chessboard with knight moves followed by an empty
line. The path should be given on a single line by concatenating the
names of the visited squares. Each square name consists of a capital
letter followed by a number. If no such path exist, you should output
impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

-

这道题其实就是马踏棋盘- -
一定要注意马走的方向还有格式,WA了9次 TAT,它要求按字典顺序输出,就是让你只能走大左上,大左下,小左上,小左下,小右上,小右下,大右上,大右下。
这里写图片描述

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int dir[8][2] = {-1, -2, 1, -2, -2, -1, 2, -1, -2, 1, 2, 1, -1, 2, 1, 2};
bool visit[30][30];
int path[30][30];
int p, q;
bool mark;

void dfs(int x, int y, int t){

    path[t][0] = x;
    path[t][1] = y;

    if(t == p * q){
        mark = true;
        return;
    }

    for(int i = 0; i < 8; i++){
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];
        if(xx <= p && xx > 0 && yy <= q && yy > 0 && !visit[xx][yy] && !mark){
            visit[xx][yy] = true;
            dfs(xx, yy, t+1);
            visit[xx][yy] = false;
        }
    }
}



int main(){
    int n;
    cin >> n;
    for(int i = 0; i < n; i++){
        mark = false;
        memset(visit, 0, sizeof(visit));
        memset(path, 0, sizeof(path));
        cin >> p >> q;
        visit[1][1] = true;
        dfs(1, 1, 1);
        printf("Scenario #%d:\n", i+1);
        if(mark){
            for(int j = 1; j <= p * q; j++){
                printf("%c%d",path[j][1] + 'A' - 1, path[j][0]);
            }
            cout << endl;
        }
        else{
            printf("impossible\n");
        }
        if(i+1 != n){
            cout <<endl;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值