Background The knight is getting bored of seeing the same black and
white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one
direction and one square perpendicular to this. The world of a knight
is the chessboard he is living on. Our knight lives on a chessboard
that has a smaller area than a regular 8 * 8 board, but it is still
rectangular. Can you help this adventurous knight to make travel
plans?
Problem Find a path such that the knight visits every square once.
The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The
following lines contain n test cases. Each test case consists of a
single line with two positive integers p and q, such that 1 <= p * q
<= 26. This represents a p * q chessboard, where p describes how many
different square numbers 1, … , p exist, q describes how many
different square letters exist. These are the first q letters of the
Latin alphabet: A, …
Output
The output for every scenario begins with a line containing “Scenario
#i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits
all squares of the chessboard with knight moves followed by an empty
line. The path should be given on a single line by concatenating the
names of the visited squares. Each square name consists of a capital
letter followed by a number. If no such path exist, you should output
impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1Scenario #2:
impossibleScenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
-
这道题其实就是马踏棋盘- -
一定要注意马走的方向还有格式,WA了9次 TAT,它要求按字典顺序输出,就是让你只能走大左上,大左下,小左上,小左下,小右上,小右下,大右上,大右下。
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int dir[8][2] = {-1, -2, 1, -2, -2, -1, 2, -1, -2, 1, 2, 1, -1, 2, 1, 2};
bool visit[30][30];
int path[30][30];
int p, q;
bool mark;
void dfs(int x, int y, int t){
path[t][0] = x;
path[t][1] = y;
if(t == p * q){
mark = true;
return;
}
for(int i = 0; i < 8; i++){
int xx = x + dir[i][0];
int yy = y + dir[i][1];
if(xx <= p && xx > 0 && yy <= q && yy > 0 && !visit[xx][yy] && !mark){
visit[xx][yy] = true;
dfs(xx, yy, t+1);
visit[xx][yy] = false;
}
}
}
int main(){
int n;
cin >> n;
for(int i = 0; i < n; i++){
mark = false;
memset(visit, 0, sizeof(visit));
memset(path, 0, sizeof(path));
cin >> p >> q;
visit[1][1] = true;
dfs(1, 1, 1);
printf("Scenario #%d:\n", i+1);
if(mark){
for(int j = 1; j <= p * q; j++){
printf("%c%d",path[j][1] + 'A' - 1, path[j][0]);
}
cout << endl;
}
else{
printf("impossible\n");
}
if(i+1 != n){
cout <<endl;
}
}
}