POJ 2488 A Knight's Journey

POJ 2488 A Knight’s Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.


Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

这道题是说,让Knight走遍棋盘上的每一个点,但不重复。最重要的一点是,输出的时候需要按照字典序输出!

按字典序!!这该怎么输出呢??
当然有办法输出了    (╯▽╰)
只要深搜的按照从左到右,从上到下的顺序进行搜索,并标记搜索过的地方;就可以了     o(* ̄︶ ̄*)o
另外还有一点,国际象棋的棋盘--横的是字母,竖的是数字 (注意:一定要按照这个格式,否则即使是答案对,也WA)
代码如下     ~( ̄▽ ̄~)(~ ̄▽ ̄)~


 #include<iostream>
 #include <cstdio>
 #include <string.h>
 #include <queue>
using namespace std;
int n, num, alp;
bool flag = false;
int x[100], y[100];
int vis[100][100];
int dir[8][2] = {{-1, -2}, {1, -2}, {-2, -1}, {2, -1}, {-2, 1}, {2, 1}, {-1, 2}, {1, 2}};
void dfs(int x1, int y1, int step)
{
    x[step] = x1;
    y[step] = y1;
    if (step == num * alp)
    {
        flag = true;
        return;
    }
    for(int i = 0; i < 8; i++)
    {
        int nx = x1 + dir[i][0];
        int ny = y1 + dir[i][1];
        if (nx >= 1 && nx <= num && ny >= 1 && ny <= alp && !vis[nx][ny] && !flag)
        {
            vis[nx][ny] = 1;
            dfs(nx, ny, step + 1);
            vis[nx][ny] = 0;
        }
    }
}
int main()
{
 #ifndef  ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
 #endif
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> num >> alp;
        flag = false;
        memset(x, 0, sizeof(x));
        memset(y, 0, sizeof(y));
        memset(vis, 0, sizeof(vis));
        vis[1][1] = 1;
        dfs(1, 1, 1);
        printf("Scenario #%d:\n",i);
        if (flag)
        {
            for (int i = 1; i <= num * alp; i++)
            {
                printf("%c%d", y[i]+'A' - 1, x[i]);
            }
            cout << endl;
        }
        else
        {
            cout << "impossible" << endl;
        }
        if (i != n)
        {
            cout << endl;
        }
    }
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值